Flashing Ramps with firmware

Does the board need power to the green connector when flashing or just the usb connecting?

I have just

The ramps doesn’t need the green power connector (but it doesn’t hurt). I read that the Rambo does.

Pretty sure there’s the problem. Make sure your connection settings are correct. To flash all you need is the usb cable plugged in.

What version of the arduino ide is best for flashing the firmware? Ive tried 1.8.1 & 1.8.3 so far.

Would it be better to try an older version?

There’s not that much difference between those versions, and either should work fine.

You have chosen COM9 from the port menu. Is that the right port? When you disconnect the Arduino, does COM9 go away? When you plug it back it does COM9 show up?

When I had it plugged into a usb3 port it came up as com 8, went through and came up with errors.

When it was plugged into a usb2 port it came up as com 9, went through and x ame up with the same errors.

OK, this is a really common problem with beginners and arduinos. Are you sure you’ve installed the drivers? After that, it’s either try a different computer, or try a different arduino.

Ok think I may have found the answer, need to change the baud rate in the firmware from 250,000 down to 115,200.

Going to try this later and see what happens.

I’ve gone into the com ports and changed the speed to 115200, have done the same in the config h sketch in the firmware. I’ve gone back to arduino ide version 1.16.3 and i still get the following errors right at the end?

This is so ridiculous !

Have changed com port,usb lead, baud rate etc.

Now i get at the end

Problem uploading to board??

Help required please

Try pulling the arduino off the ramps board and connect only USB.

Have tried that Jacob doesn’t make any difference

You can not change the buadrate without changing the firmware. The first error was common and just the wrong port, the second error looks like you opened the wrong file or something.

You could very well have a bad arduino, or COM port issues (not common in newer machins), at this point it is hard to tell. Nothing is indicating it has ever worked.

Just to clarify are you saying to leave the baud rate in the firmware at 250000, even though my usb2 ports wont go above 128000 max.

Is it a bad mega 2560 in that case? I have a replacement coming tomorrow, in order to try again. I so need to be able to get my mpcnc as a printer up and running.

In your opinion are ramps setups a bit unreliable?

I have never heard of a windows machine with buadrate issues, but if that’s what it takes you have to edit the firmware to match. Or if you do get it to flash and you still will not be able to communicate with it.

Also where are you getting these boards from?
Some are poor quality using chips require funky drivers and usually they say or link it in the description. At the same time yes there are serious quality issues that is why mine cost so much, tons of them have issue I have to build and test each one with every single port we use because there are tons of problems. I switched to the minirambo for this reason. I even have a post selling bad boards for parts for $1 because I have soooo many of them.

I bought it as a complete kit from ebay.co.uk. the screen seems ok and lights up. As far as I know the ramps part is fine although I havent connected up any motors etc because I cant get the firmware to install to the mega.

There is no way to know until you run it all. Sometimes the screen won;t read files, the motors will only move one way, endstops are permanently triggered, mosfet stuck on, so many stupid little things, I am not trying to scare you but until it moves and you make a test drawing you are not out of the woods.

Have a look at amazon for the description to some of the ramps kits, you will see a bunch need a special driver, you might want to try that.

The baud rate setting in windows does not matter. Maybe try flashing the basic arduino blink example :slight_smile:

Another think that could be wrong is another program is hogging the com port. I think repetier-server does this (not sure it was repetier) and Simplify3D also likes to do it (if you have it running only).

All the error logs you have posted in here so far looks to me like the com port is either not working, or something else is using it.

anyone know what the com port settings should be?