Flashing Rambo 1.4

Hmmmmmm. I have them both in there, not sure why “.io” is not working.

I was able to get Reperier to talk to the board and the laser, in that I was able to draw/burn the crown. but I had to use the manual control to turn on and off the laser as well as set the intensity. I also noticed that when I manually turned off the laser there was a lag from when I pushed the button and when it actually turned on/off.
the button i pushed to turn it on/off was the Fan button. is that because I reassigned the fan button to work on pin 45? how come it doesn’t know to turn it on/off on it’s own? Also the M3/M5 commands didn’t do anything.
I also could not get the LRv2 to talk to any other program, like Lightburn, or Estlcam.
any ideas?

1 Like

In my experience M3/M4/M5 are usually mapped to the Spindle Enable and Spindle Direction pins. If you’re using the fan control you’re probably not using the spindle pins.

I was told to map the fan pin to 45, I noticed that the spindle_laser_pin was also on 45, see pics earlier in the feed.

At this point I’m going to step back and watch from the sidelines. My experience is with other boards and firmware, so I don’t think my knowledge applies in a way that can help solve this issue.

1 Like

I am almost there with the laser. I have been burning for a few hours the last few days.

1 Like

I finally got my laser to work! It took some testing of the baud rate to figure it out in Lightburn. Oh, and it uses the M105/106 command. Now I need to ask, is there a specific height the laser should be from the work surface? I know the beam focal point adjustable. Still waiting on a fan to help with clearing the smoke, should be here soon.

Don’t mind the burn holes, that is just the times I was still figuring it out.


When I plug in the USB cable my Rambo board freezes, and I have to cycle the power. Has anyone else seen this and is there a fix?