First time setup of FluidNC

I have finally got to the point of powering up my LR3 and up till now I have found the documentation has been easy to follow. Where I have got stuck is the communication with the Jackpot board.

In my case, it doesn’t help that I am much more comfortable with mechanical parts and hard wiring electrics than I am with software loading and setup. However I have wired up my Jackpot board according to the guide and when I powered up the LR3 for the first time I was able to confirm all of my limit switches were working as they should as indicated by the LED lights on the Jackpot.

I am trying to follow the bouncing ball and reading the guide it says, “if you bought the Jackpot board from the V1E store you are ready to go…” I did buy the Jackpot board from Ryan so it should be good to go. I tried to go to but this brings up my modem login page? When I look at installing FluidNC I am confused as to whether I need the WiFi or Bluetooth version? And I am not sure how these relate to AP or STA modes? Also I don’t want to overwrite the factory install of FluidNC that is on the Jackpot already. Perhaps a Bluetooth connection is an AP mode and WiFi is a STA mode?

I have managed to install Klipper on my 3D printers so I am not a complete novice on this stuff but with the Klipper installs YouTube videos were there to guide me through the process. Am I missing some more detailed instructions? Any tips on where to go from here is appreciated!

Cheers Andrew

" " follow the instructions to set an static ip to your machine (it would be easier) enter the dchp reserve table .

You can enter just using Fluidnc.local in your explorer if the Jackpot is already connected to the wifi, if is not: open your wifi settings and conect to it

Congratulations on getting your LowRider put together and powered up.

First, try what cesar mentioned above. Connect up and try pointing your browser to fluidnc.local. If that gets you the FluidNC web GUI then you’re ready to go further.

If not, then we will need more detail about how you set up the Jackpot controller.

FluidNC can be set up in a couple of ways. If you set it up in STA → AP mode, then if FluidNC has trouble connecting to your AP it will fall back to still setting up its AP mode. When you look for WiFi to connect, do you still see an AP named FlluidNC?

Andrew, the Jackpot has built in wifi. That is what AP (access point) means. AP is the default setting. On your computer you first need to connect to the Jackpot’s wifi (Fluidnc). Then you can go through the settings and have it connect to your wifi if you want. If you choose to do that, the best thing to do is set it up with a static IP address.

1 Like

Yeah. If you can reach your router’s page then you haven’t connected to the fluidnc wifi (unless you already reached the fluidnc and set up station mode).

Looks like I should add a screenshot of this in the docs. I don’t think this is the first time I have heard of someone missing the “connect to the SSID” step. I didn’t know what an SSID was off the top of my head until this Jackpot journey myself.

I don’t have a mac or iPhone if someone wants to grab a quick screenshot for the docs. I can do windows/android…although that is probably enough to get the point across.

Sorry Andrew, that was my bad, should be easy from there.

Thanks for all the quick and useful replies. This forum provides awesome support and a great security blanket for people starting on the CNC learning curve.

I can see the error of my ways! I will connect to the FluidNC wifi and try again later today. I should be able to make some more steps forward.

So the default setup of FluidNC on the Jackpot is “AP” mode / bluetooth connection from my laptop directly to the Jackpot/ESP32 (once setup of course)? And if later I can see benefits in using the “STA” / wifi connection then I need to reinstall FluidNC with the wifi version. This being done with a unique static IP address like Klipper does with the 3D printers?

AP is still wifi. You can change to sta on the web site it opens.

IT WORKS!! I can see now that it is wifi not a bluetooth connection. All the stepper motors are working but some moving the wrong way. I believe I just need to reverse the plugs to correct this.

I am using an old Windows 10 laptop to interface with the LR3. To get it working I needed to connect to the FluidNC wifi and this drops out my modem wifi, so no web browsing available when I am connected to the LR3. Is this just the way it is, only one wifi connection at a time? Perhaps this is the advantage of an STA connection?

Exactly right.

It is. in Access Point mode the Jackpot acts as a hotspot, in Station mode (sta) it acts like a wifi client and joins your wifi network - if it can’t find or connect to your network it has a ‘fallback’ where it’ll then create a hotspot. So if you are in STA mode and see the jackpot’s WiFi you know it’s not connected.

Some people have issues with signal in STA mode if their wifi router is far away so check the esp32s antenna isn’t covered by your wiring.

1 Like

That works fine. You can alternatively change the dir pin in the config.yaml. Which is easier depends on your skills.