ESTLCAM Wrong Size - Tips

Took me a while to figure out why my cuts were sized wrong.

Dealing with Inkscape (SVGs)…

EDIT: STILL BE WARY. Some things are off when measured but it’s small precision issues. (Hundredths of mm). Though, small objects error goes away when zooming in and re-measuring carefully. Can’t do that with large objects that I can find. It would be nice if rt-click select showed the max XY dimensions of that line. So this is very close but???
EDIT 2: See the marked solution, set to use Geometric Bounding Box.

Just the steps;

  • Select All; Menu > Edit > Select All in All Layers
  • Deep Unlink; Menu > Extensions > Arrange > Deep Ungroup > Apply
  • Object to Path; Menu > Path > Object to Path (NOT Stroke! doubles lines)
  • Rectangle; Draw a rectangle of known size around all objects.
  • Save; Menu > Edit > Save a Copy > (I end with …_DEEP_UNLINK_AS_PATHS.svg
  • import; adjust width; set known rectangle size.

TIP: you can measure things with center mouse wheel.

Sadly I thought this didn’t really matter. I thought it was everything else.
I was mixing mm and inches sizes in my drawings, not the issue. Not an export conversion precision issue. I drew a rectangle of known size around everything and “adjust width”. This helped width but heights were still off. Internal circles were off. Alas, when I combined both tips it worked. My 1/4" circles are at least drawn as 6.35mm now). I have yet to “cut” them. I see a few other threads on size issues including undersized holes so I though I would post in case it helps someone else avoid. Also note that when I did stroke to path it doubled the lines. Which I discovered I could select and delete with a right click but just use Object to Path instead to not have to deal with the extra lines.

TL;DR Follow the import tips

DXF seems to be slightly worse. Export to DXF 14, units mm. 74.83mm rectangle height instead of 75mm and no adjust width available on import. 159.83 width instead of 160 known width rectangle. So at least SVG has adjust width to get us close.

Line Selection for measuring.The snapping is supposed to handle not going over but It is also hard to select perfectly vertical or horizontal some times so I expect some hundreths off in these cases. (look for 0.00 in the opposite plane to know vertical/horizontal). The usual shift or control click don’t constrain the plane as expected.

The default Inkscape setup is for graphic artists where line/stroke width matters. To get center of the line/path dimensioning select the Preferences : Tools : Geometric bounding box (see also: .Dave Lers : Workshop : CNC : Inkscape).

1 Like

wow cool That works great. Thanks. It took me a few minutes to realize I had to fix all my raw SVG sizes as they had changed. But all the sizes come out right by default. Many Thanks. That’s so much easier. I may have to adjust some originals though. Not too sure how I am gonna go about that. But we have a solution to accuracy at least.