Estlcam w/ CNC Shield setup issues

I’m trying to convert my CNC fully to EstlCam.
It has an Arduino Uno + CNC Shield setup. I’ve been using GRBL on the Uno and CNCJS for a while now, but I really like the Estlcam software so far. Unfortunately, configuring the CNC Shield is not working the way I’ve expected.
The best configuration I’ve gotten so far is that all the steppers work properly, and the setup software recognizes the X & Y Limit switches, but doesn’t see:

  • the Z limit switch (shield Z Lim Sw -> Uno 11)
  • the probe ( shield SCL (in I2C area) -> Uno A5)
  • the pause/hold button ( shield HOLD -> Uno A1)
  • the restart/continue button (shield RESUME -> Uno A2 )
  • the Emerg Stop button (shield E-STOP -> Uno RST )

These functions all worked properly with the GRBL setup, so I feel sure they’re correctly connected. But the Estlcam Setup / Inputs page doesn’t see them when I activate them.

What am I doing wrong?


My CNC Mill with UNO and CNC Shield only has the probe function in use and it works fine in conjunction with Estlcam with Grbl (All) layout. Since it is an all metal Mill, I have to insulate the probe from the spindle and connect the probe directly to the UNO.

I don’t see the need for a Z limit since I use a variety of different length cutters so the limit would need resetting. I rely on the the software and the Machine - it only fails when I forget to reset the Z = 0 on a tool change! (It would be a good idea to have ESTLCAM sound an audible warning alarm as a reminder before resuming!).

The other outputs as above I have not used, since the software has pause/resume.

So, just to confirm, you have -

GRBL selected so the pinout is as shown in the right rindow

and -


your inputs set up like this?

If this is correct are you saying that if you manually trigger the Z limit switch the indicator in the CNC controller settings page does not respond?

No, my Eingang 8 Probe does switch to red triggered - just tested it.

So that is working ok then…have you tried the ‘touch off’ icon (second down on the right hand side of the CNC controller page (after loading a job), and does the indicator switch to red when each of the limit switches (X,Y and Z) are activated?

You can rename the eingang labels…left click to highlight and change the name to something you will recognise.

Thanx Mike
Yes - that’s my setup.
And correct, the Z limit switch never turns on when I manually trigger it. Same for all of the other inputs. Only Limit Switch X & Y are working properly.

But now I have developed a different problem, namely that I can’t the CNC Controller software to the Uno. I get:
No Response
Wrong hardware or port selected?
Retry …

Go figure! Should I start a different thread for this new issue?

The probe sets the X and Y, and I visually touch off once I have fitted the cutter.
I have not experimented with any other inputs other than the probe. I have no need to use them. I use an XBOX controller so have a stop/pause control in hand. The software stops for a tool change and I then have to initiate the ‘continue’ either on the XBOX or on the ESTLCAM screen .

Ryan’s advice of not using limits on my MPCNC long ago has converted me from the need to have them.

Hi Bluff
Thanx for the input. I have become quite fond of the XYZ limit switches, as well of all the other stuff I put on my machine. I guess am just trying to make it as monkey (me) -proof as possible.
To each his own eh?
But regardless, again - thanx for a different perspective - always something to think about.

1 Like

Next step would be to check the z limit switch with a meter then, tracing the signal back through the cnc shield and on to the Uno pin.

No Response problem is either wrong port, wrong baud rate, something else using the port, faulty USB lead or a duff Uno…probably in that order. You can also click on the usb/com port down arrow under CNC controller/Controller to check if Estlcam still sees the com port.

It might be worthwhile just disabling your xbox controller to eliminate that (and Microsoft XNA framework) as the possible problem source.

So…I assume you have not set pause,start and stop in the inputs page as those functions are available on the xbox controller

Hi mike
Yeah - I already traced the path w/ continuity.
But I like your suggestions for tracking down the second problem - my money’s on the Uno being -1. Too many other weird problems.
I’ll get on that today & let u know

Hi Mike
OK - well the short story is that it was a problem in my ratsnest of wires and kludges that connected the machine to the controller - I’ve been intending to clean that up anyway, so now’s the time.
Thanx so much for your support.

1 Like