Estlcam isn’t saving the post processing file

I’m having some serious problems updating my LR3 to the jackpot controller.

Estlcam isn’t saving the Fluidic post processing file

It seems like every time I put my iPhone down it disconnects me from the controller.

Code files don’t run. I got a very simple one to run that I assembled by hand. I tried a number of different post processer code.

I can no longer talk to the controller from my computer with a usb cable or wirelessly.

I can jog the machine ok.

I’m sure there are solutions to these issues I just don’t know what they are

This sounds like separate issues. What does Estlcam not saving files have to do with the CNC not moving? Could you specify that, please?

I’m still trying to pinpoint exactly what the problem is. Some of the gcode files won’t run because there are comments with parenthesis that won’t run but the will run after I comment out those line with semicolons. Also some of my older gcode files seems to run fine on the new controller.

Some of the gcode header files looks strange. Sometimes it puts the FLuidNC.pp info and sometimes not even after I load it on Estlcam. It’s as if the gcode interperter on the controller will stop if it finds a character it doen’t recognize. I’ve been able to run some gcode files but it’s kind of hit and miss. I need to spend some time analyzing some files to see what makes a difference. Any suggestions or ideas would be appreciated

Sounds like you don’t have “GRBL” selected as the output type

I do select it but the next time I look it’s been unselected. When I used the old board Marlin always stayed selected. I’ve loaded the FluidNC.pp files several times but when I create another gcode file the FluidNC header is gone

what version of EstlCAM are you using?


Regarding the iphone disconnects, switching the jackpot to station mode (ie permanently on the network) made things work much better for me. I know the wiki recommends against it but I had no problems - it takes a little bit of networking know-how but then you have what feels like a permanent connection.

I gave mine a static ip address and matched it in my dhcp configuration, but it should work the same just using regular dhcp. Either way you can then reach it at fluidnc.local. The setup feels a bit scary but one nice thing is that if you get something wrong and it fails to connect to your wifi it falls back to AP mode, so as long as you don’t disable that you can’t break it to the point where you can’t fix it.

One important note - make sure you only connect to it via one device at a time. Pulling up the gui simultaneously from your phone and a laptop uses too many resources and will lead to (possibly intermittent) out of memory errors. Took me a while to figure that one out.

Have you gone the basic troubleshooting route? Uninstall/re-install?


the “GRBL” Selection in the list is just a preset
Clicking it it will set the according values and those values will be saved upon program exit.
But the list selection itself will disappear as it has no meaning other than loading a preset upon clicking.

Comment start characters are different for different controllers -some expect “(”, others “;” and a few something totally different like e.g. “#”. You can change all texts in the CNC program settings dialog to use the character your controller expects.


Check out “DHCP reservation” in your (I assume) router configuration. You put the MAC address and the desired IP in the router and leave the device itself as DHCP-configured. This gets the device the same IP every time without having to manage the address in both places (the router and the device).