ESTLCAM Cutting Plane Starts at Z not build surface

Hi, its me again. I updated my ESTLCAM to the most recent version. I have designed something to be cut out but when I go to the preview it starts at the bottom and works its way to the top. I have added a picture of what it is doing in ESTLCAM and my settings. From what I see they are all correct. I thought it was a bug with ESTLCAM and ran the program. It started out fine the rammed RIGHT into the board I was trying to cut and I had to stop it.

1 Like

Starting level is at 0.00mm and toolpath depth is set to 12.00mm.

Did you set 0 correctly at the top of your workpiece? If you have set 0 to your spoilboard, it will obviously want to start there.

It is set to:
Z-Axis origin: workpiece top side.
CNC program start: at origin
CNC program end: at origin

I can see that. You have to tell the program that the top of the workpiece is 0. Did you do that?

I must have missed something then. I thought I had it set to the top. Where might I check that? I haven’t used in a while and updated to the most recent version only to have it reset my settings

And I made the rookie mistake of not saving my settings file prior to update! I also found a start code where it is supposed to use the z-probe. Are you familiar with these? If so would you mind if I put up to see if it is correct.

Robert gives the needed hint in another thread, see above. :slight_smile:

1 Like

I put this in my start gcode but also have it set to do a G92 for the z probe but it crashed into it and never registered by zprobe. I used to use my computer hooked up to the machine to start all of this but I want to not have my computer next to it as I also use this same computer for my laser. The other day it started in the air and never went down. I probably have them out of sequence or something. Here is what I have listed as my Program start gcode but it does not work as I intend intend it to work:

G92 X0 Y0 Z0 ; Set Current position to 0, all axes
G28 Z ; Home in order, w/zprobe
G92 Z0.5 ; Account for probe thickness (set your thickness)
G00 Z10.0000 F500 ; Raise Z probe off off of surface
M00 ; pause for LCD button press
G28 Y ; Home Y
G28 X ; Home X
G92 X0 Y0 ; Set current X and Y to 0
M00 : pause for LCD button press;Project
;Created by Estlcam version build
;Machining time about hours

M03 S

1 Like

G92 is not correct if you’re using a touch plate.

G38.2 z0 ;move Z down to touch plate
G92 z0.5 ; set Z as thickness of the touch plate above work surface.

Why are you setting the current position as 0,0 then homing twice before setting the now homed position as 0,0 again?

I do not know. I am unfamiliar with all the gcodes. I found one on a forum and used it as the person said it had worked for them. What do you recommend the Gcode be for the start then? I really just want it to home to x,y and then home to the z plate and start from there. Thank you for the help. Still havent figured out why my files are starting from the bottom though in estlcam. I have looked at everything I thought possible and it all states top and z axis origin at workpiece top side. I will have to try the new code and see what happens. Maybe it is just a display thing in estlcam, I am unsure as or yet.

Okay the gcode to do that is

G28 Y ; Home Y
G28 X ; Home X
G92 X0 Y0 ; Set Current X and Y position to 0,0
G38.2 z0 ;move Z down to touch plate
G92 z0.5 ; set Z as thickness of the touch plate above work surface.

Starting code is very much a preference. Personally I use the touchscreen to home each axis and zero the z to the touch plate before every job. At some point I might even get round to using the custom menu instead of typing the g38.2 command into the erminal each time. But today is not that day.

Why I like to do that is is I am testing the movement each time and it makes it easy to do things like take the z, move it 50mm up, set that as 0 and do an ‘air cut’ test of my file. I couldn’t do that if the first thing my gcode did was try and re home.

If anything the simplest start gcode for me to use would be;

G92 x0 y0 z0 ; wherever the tool head is right now, count that as the origin

And use the touchscreen to put the tool to where I want to stat from and go.

Thank you. I would love to do it from the touchscreen. I do not know where to go to make it zero to the touch plate, which is why I always used my computer. I am trying to get away from using my computer and just use the touch plate and set my workplane.

From the touchscreen there is a ‘terminal’ button. I think it’s in the bottom left. From there you can enter gcode commands, that’s the way I use it.