EstlCAM 12 - Trochoidal Rapid Moves Aren't Rapid?

I’m sure this is likely something that I am doing wrong, rather than a bug in EstlCAM

I set up the Rapid X/Y and Rapid Z in CNC Programs / Post Processor (3000 for X/Y, 900 for Z).

I have a project where most of the holes and parts are using trochoidal milling, but some smaller holes require the use of non-trochoidal milling.

When I save the program (create g-code), it seems that the G00 commands for Z moves all have the correct feedrate (900), and the G00 X/Y moves for the non-trochoidal tool selection has the correct feedrate (3000), but any of the G00 X/Y moves in the trochoidal tool section have an undefined feedrate (using last specified feedrate)

Trochoidal snippet:

Non-Trochoidal snippet:

Any idea what I am doing wrong here?

OK, I’m answering my own question here. I was using Trochoidal Oscillation (set at 0.10mm), As soon as I set that to 0, the rapid X/Y moves showed as 3000 mm/min, and the overall project time was reduced by about 15 minutes

With the use of misting and proper chipload (fingers crossed), perhaps I won’t need the oscillation setting to prevent chip welding in soft aluminum.

1 Like

You should be fine. I don’t use that in aluminum

1 Like

Rapids are G00 positioning moves, oscillations are G01 cutting moves.

Yes, this is true. But it seems that when trochoidal oscillations are used, G00 movements don’t have the rapid speeds applied to the code (or at least not in this case). Perhaps because the G00 X/Y commands also contain Z movement.

Enable Repeat for F…… Note: Setting rapids and feedrate repeat (oscillation is just an example of why you need to enable it) Values are controller specific, e.g. they are not needed when using Estlcam firmware.

That didn’t change the behavior (still using last specified F command for X/Y G00 instead of Rapid feedrate), just adds the slower speed to EVERY line of gcode.

I did lower the Z rapid to 600 (from 900) after reading a forum thread where it warns of missing steps if Z Rapid is set too high.

The only G00 lines I see all include a Z and doing them at the Z rapid feedrate makes sense. It’s the F on the G00 X,Y,Z lines that’s setting the speed for those ‘move in three directions at once’* lines. Only G00 X,Y lines will have a F3000.

*The thing that’s bugging me is I’d swear there are cases where the Estlcam controller moves the Z first on G00 X,Y,Z lines, e.g. after a tool change, but executing an X,Y,Z command is done as a single move.

Yes, this seems to be a “feature” when oscillations are enabled. The oscillations seem to be applied even to G00 commands, not just G01 commands. This seems to be preventing the faster X/Y Rapid feedrates from being applied, instead the slower Z rapid feedrates seem to be used instead.

Disabling oscillations seems to eliminate any Z movements during Rapid X/Y commands, and the faster X/Y Rapid feedrates are applied.

Perhaps if @christian-knuell stumbles across this thread, he could determine if it is possible to remove the oscillation from G00 Rapid moves (if that is indeed what is happening).

1 Like

Hello @christian-knuell, ran into this as well.

Expected behavior: “Trochoidal Oscillation” value should not impact Rapid XY setting. Where Rapid non-cutting motion has been configured in “Rapid XY” text field (e.g. 5000) found within Setup menu, CNC Programs / Post Processor sub menu, Values tabbed dialog.

Actual observed behavior: Like @Bartman, I’m observing really really slow Rapid motion for non-cutting movements between operations if Trochoidal Oscillation is non zero (e.g. I set 0.05 for Polycarbonate cut, no idea if that’s good or not).

Workaround: Like Bartman said already, updating router bit Trochoidal Oscillation setting to 0 results in expected speeds for Rapid motion. :man_shrugging: don’t understand why non zero Oscillation affects Rapid.

I haven’t updated in a while, so maybe latest has changed/fix already, version… shp 3,070,776 12-21-2023 estlcam12_cam.exe


please send me an affected project file - I’ll have a look at it.


1 Like

Sure thing, hope this helps… (598.8 KB)


I have sent a project file to you via email. Hope that helps!


the issue should now be fixed (I hope).