Estlcam 12 Bug in CNC and another in CAM

I was having some problems with a new control box I have built for my old machine that was running version 11 of Estlcam.
I traced my problems down to some faulty wiring in my new control box so I re-installed my old control box that I had successfully used with version 11 for some years.
I used Estlcam version 12, latest version and also the version previous and I found problems in both.
The part was designed in version 12, but when I tried to cut the part out, the system froze with the spindle going at 24000, I was not able to close the program, or stop it in anyway except for pulling the plug and closing the computer down.
I tested with both the last two versions of 12, same thing happened each time.
I then loaded the same cutting file into version 11 and it cut flawlessly twice, no freezing or any problems.
Also the very last version of 12 released on 24 Dec has some bigger problems in the CAM program.
When a file is loaded it does not display on the work area. The work area is also blank and the grid doesn’t show either. If you run the mouse over the work area the lines of the part become visible in green, but as the mouse leaves that area the lines disappear again.

I’ve been using estlcam v11 for years and a few days ago I decided to switch to v12.068 ,
but the problem appears that the “estlcam cnc panel” blocks when accelerating the spindle.
Not all the time, but in 70% of cases after pressing start it gets stuck as in the picture show.
My delay time is set to 3.0sec and as you can see in the picture it blocks with the message “RPM change: 2.9s…” and just like that it stays blocked with the spindle working at set rpm, but Gcode not continue to execution and remains trapped in this place.
In estlcam v11 it never happened to get stuck in any sense.

To finish the job today with v12 , I set the time to accelerate to 0.0sec and after that it worked, but every time at the start I had to manually slow down the machine feed rate do 0 until it speeds up the spindle.

That sounds very much like what I am having happen with my machine.
My spindle will start up to speed OK, but when the gantry moves to the very first position the program freezes, I can’t do anything with it except turn on and off the LED light that is controlled by output 1. Everything else is locked, including turning off the spindle and shutting down the program. Actually it is very dangerous as I have to use Windows Alt Ctrl Del to bring up the task manager and shut down that way.
Yesterday I ran a small job and had to try 7 times to get past the first movement, after it past that position in the code all went well until the end.

Did you find a solution Danijel?
I have built another controller because of this problem, and although I have followed very carefully to ground everything and also use ferrite cores on the wiring, shields everywhere that I can put them and an EMI filter on the line, ferrite bead on the USB cable and also the cable is fully shielded. It still happened using an air cut on my computer, machine not connected to the controller.
The freezing always freezes in the same position no matter which file I am using.
It can’t be because of the spindle, because there isn’t one connected. No limits either or probe.
I feel it must be some software problem that happens from time to time, because it doesn’t happen all the time.
always freezes here.

Maybe you could post a .zip with both the troublesome project file (.e12) and the G-code (.nc) that it generates on your system. Seeing that you G-code coordinates only have three decimal places (VS default four) I wonder if starting from scratch with as many configurations options as possible left at their defaults might help (e.g. Dave Lers : Workshop : CNC : Estlcam : Setup).

Thanks Dave,
I will try a set up again and see if it helps.
As for the files you ask for, it can be any file, it happens at random, maybe 10% of the time with V12. I have to change over to using V11 for CNC when it happens,