Dual endstops homing XY moves Z axis down


I am building a lowrider2 with a kit incl RAMBo 1.4 with dual endstop and Z Probe but have run into a problem with homing.

I flashed the RAMBo 1.4 with Marlin_V1CNC_Rambo_DualLR_2.0.9.2_513 using XLoader.

I just tested all the endstops with M119 via this guide Dual Endstops Low Rider - V1 Engineering Documentation and everything seems to work.
All endstops is by default open and triggered when activated.
I have how ever not testet the Z probe when activated yet.

The X axis moves to the right, the Y axes both move away from me and the Z axes both move up.

I wanted to do a test of homing the X axis with G28 X. but instead of home X. both Z axes moved down. Same with G28 Y. instead of moving the Y axes Both Z axes also moved down.
On the other hand, both Z Axes moved up when I tested with the G28 Z

This may be a silly question, but is it not wrong and how can it be it does that?
This is definitely not how my 3d printer will react

Also when I tested homing the x axis I tried to activate the x endstop to see if it responded to it. - Which it did not.

One last question. can I get the Y axis to home away from me instead of towards me?

I think this is the safe home Z. I bet it is moving down, instead of up, because of the inverted homing direction in Z.

This is exactly how my printer works, but it lifts the Z up when homing.

The dual LR firmware isn’t as well tested. I would not be surprised if this has always been there.

The best work around would be to home Z first. That is probably appropriate anyway, since you don’t want to collide with anything on the table.

That is strange. If M119 is right, and the axis moves the right way, then the logic is very simple (and well tested). Did you do that after it did the Z movement or during?

This is really not that simple. Unfortunately. Reversing the Z to go up took quite a few setting changes. Basically, you will need to set the Y_HOME_DIR to +1, but then you have to change the Y2 endstop to something other than ymax. It would make sense to use ymin, but last time I tried, that didn’t compile.

if I as you suggest do a homing of the z axis first. then everything else works as it should …

Thank you very much.

1 Like