Dual endstop firmware

Is there a preconfigured version of this anywhere? I’m trying the version from github, had to modify it for the lowrider. I enabled dual z, that works, but I only have one y motor working, I also need to figure out how to disable the steppers for now.

I can send you one. You turned off dual X, added Dual Z, that would put Y and E0 a pair and Z e1 as a pair I think.

I need to look, I have a ramps in the garage.

Having both Z work and not both Y is odd, Normally the second one is the issue because of the pin shuffling I have to do.

Okay, looks like I missed an uncomment. I commented the enable dual Y, and now it’s complaining about not enough stepper plugs for z2…

On the hardware, it couples Y2 with E0, Z2 with E1.

On the software, you set all E0 pins to 70, E1 pins to the E0 defaults and E2 pins to E1 defaults.

That will define a fake E2, set to E1, which it will use for Z2!

Are you planning on putting dual Z endstops in?

Right now, no endstops, but eventually yea.


Okay, where do I change the pin setting?

looking at it right now


Changing only these two lines it compiled for me. If that is what you did and it is still being a pain use the arduino nightly/hourly.


Yea, that’s what I changed, then it said not enough pins… Tried Jeff’s pin reassignment, that got it working. Need to make some jumpers for pretend end stops for now.

Using the github dual ramps version I have? I can zip mine and send you a link

Yep, I’m using the github version. I think I have everything working now.

Well the file structure of that looks completely different than the one I downloaded, but this one won’t open for me. Which version of arduino should I be using for this?

Freaking windows… Nevermind, got it. Can’t work out of a zip file…

Step 1) install linux.

Arduino gives me enough shit now, don’t need to add linux on top of it. I’ll stick to the one I edited. The latest one from Ryan’s dropbox just scrolls errors. :roll:

Ok. That might not have been the best advice…

Those errors are because you need the bleeding edge Arduino for 2.0 in windows. I’m not sure what you downloaded, but my guess is you didn’t pick a version from the branch drop-down and you hopefully ended up with 1.1.9. If you ended up with a bugfix branch or something weird, then you might get some unique bugs.

We should probably have a dual endstop low rider configured. We should probably also be based off of 1.1.9, instead of 2.0. I’m not sure if that second one is a step back or not.

Are you thinking the Z will home to Z max? I think that requires some other firmware judo. I’ve worked through it with someone here, but I haven’t done it myself.

I really only need x and y homing, but right now I just want it to move! :lol: I downloaded the nightly, so it’s 1.8.6.

Arduino 1.8.6?

Ryan’s github defaults to 1.1.x from 11 months ago…

I can whip something up after the kids go to bed tonight.

Crud, I forgot about all this stuff. On the firmware page if you scroll down to the beta section it tells you how to set up the new temporary directory for Marlin 2. 0. The final version of marlin 1. 0 keeps getting pushed back and I was waiting for that to happen to just finalize the dual for that…

I should have just edited the 1.0 version for you. I’ll be back at the computer in a bit if you don’t get it by then.