Crown test stopping

Hello All,

the cnc stops while trying to draw the crown, I used v1 engineering test file and created 2 different files using estalcam 9 and 11 with repetier host 2.2.4, any help is appreciated

You need to explain a bit more about what is going on. The first file you should run is the pre-made g-code file of the crown. You can find a link on this page. It does not require EstlCAM since it is already in g-code format. You can either run it from an SD card, or you can send it to your machine using Repetier-Host. Running this pre-made file helps you figure out how your machine is running without having to worry about EstlCAM setup issue.

As for the file you produced “stopping,” you need to explain a bit more about what you mean. Does the machine just stop, or does it keep running but not drawing? Are the steppers still engaged? Are the electronics still on? Is the machine making any specific noises? What control board and firmware are you running (if you are unsure, post a picture)? Etc.

Posting a video of your machine as it stops, and/or posting the g-code file can help us troubleshoot what is going on with your machine.

Can you repeat the issue? Does it stop at the same exact place every time? I wrote this thread with a similar question: LR2 keeps stopping while cutting - #2 by jeffeb3

Thanks for your reply, please see below:

Yes, this is the file I’m using and it’s stopping at the same position always, while loading the file on Repetier-Host it’s showing 2min 40sec but on the machine, it’s only 1 min 17 sec and stopping, the matching is still running normally it’s just stopped there like the code it’s finished there.

For the file, I made it according to v1 engineering instructions using EstlCAM 11 and Repetier-Host2.2.4 , it’s working ok but it’s homing before starting I believe because it’s missing g92 command and the issue with it is that the z axis not going up between the shapes see the picture below.

I’m using the sd card as I couldn’t figure out using Repetier-Host with the computer I tried but I believe I’m missing the driver for the controller.

I’m using [SKR Pro 1.2], and also could find where the firmware version is mentioned.

Hope this will help,

Yes, it’s stopping at the same position always

This is strange. Since you are running from an SD card, please upload the file directly from the SD card to a post here.

1 Like

Where did you get that firmware? It looks like it is from bugfix, which isn’t always stable. The firmware should be from MarlinBuilder releases. The DualLR version, V1CNC, skr pro 2209.

I wouldn’t expect even bugfix to be that broken. But it is really hard to debug custom firmware through the forums.

It could definitely still be an issue with the gcode, so pasting that would be helpful.

The gcode file here: test crown. Is known to be good. I could imagine it got halfway downloaded and didn’t get the whole thing or something. But please use the gcode found there instead of trying estlcam first. If that premade gcode is broken, then we have to fix it. It has been used on hundreds, if not thousands of machines.


crown.gcode (106.9 KB)

I got the file from the link below

I didn’t upload any firmware, this is how I got it from V1 Engineering should use the one highlighted below


I tried to paste it but it’s showing me I’m passing the limit, and yes I’m using the file from the link you mentioned.

Just to be absolutely sure. This file was pulled directly from the SD card? I ran a diff between your version, the version in the ZIP file, and the version linked in the page I referenced above. All three versions are identical, so assuming this file was pulled from the SD card, the issue is not a corrupted file. Just in the off chance of some issue, consider putting an original version of this file on a different SD card and running it.

1 Like

You have a low rider, so it is the one right below where you highlighted. DualLR.

@vicious1, This screen says it has 17203e1 bugfix on it. Is that something you have been flashing on skr pros to ship? Is there any reason 513DL isn’t working for LRs?

I did the update but the issue is still the same

No, if it has a bugfix on it it means I had run that bugfix and tested it on my build, should be fine as should 513DL.

Hold the button down on the screen and run it from the touch screen mode, see if anything is different. If it stops in the exact same spot it has to be the file.

1 Like

Problem fixed, you made me suspect everything so I repeated my steps and check the files with Repetier-Host, what I found is that when using a card reader to transfer the file, it was getting corrupted, just not sure when exactly this is happening as the file I send you was from the SD card too, before going with a different card I used a laptop that has a built-in card reader and it worked fine.
Thanks for your time and sorry for that, I never came through a situation where a card reader can cause file problems.

1 Like

Thank you both, seems that the issue was caused by the card reader I was using not sure why, but after I tried using a laptop with a built-in card reader the issue was fixed.


That has happened to me before. I am still not sure where the issue was, but I hadn’t copied the whole thing onto the card.

That is part of the reason Robert was asking for the file off of the sd card. I saw that, and thought you would be covered. Oh well. Glad it is working again, and you have the same firmware now. Nice work.

1 Like