CNCjs just released version 1.9.16

A heads up for the ones that use the CNCjs, yesterday they released an update, now the latest version is 1.9.16.



from Nicosia, Cyprus


I need to compile a new v1pi image, but if anyone wants, The cnc.js update instructions should be fine.

1 Like

anyone here have a working ps3 controller on cncjs ?


I think that would be great. It’s something I wanted to put in v1pi, but I was hoping for the more generic joystick inputs, which could handle a lot of controllers.

So I just downloaded and installed CNCjs on a windows laptop… I’m able to control the MPCNC (after sending a manual command from the console first - seriously? are they going to fix that?) but I can’t figure out how to connect through my phone or tablet.

The CNCjs host laptop has an IPv4 address of, so if I understand correctly I should just type in my browser right? It doesn’t work, says site can’t be reached refused to connect… So I tried disabling the firewall and that didn’t work either.

Any ideas?

I don’t know windows, but there are options on the command line for starting cnc.js. One of them determines which inferfaces to host it on. (–host in usage)

Looks like it defaults to, which should be all of them.

Other than that, I still blame firewalls. Because I always blame firewalls.

1 Like

Well, it wasn’t the firewall… Turns out it wasn’t using the default host as advertised, it was using a different IP and different port every time. Based on your tip I modified the shortcut target properties in windows to run “C:…\cncjs.exe --host --port 8000” and now it works! Thanks!

Happy Day!!!

How do i update the CNC.JS on the pi image? I am sure it is a terminal command. Just not sure what it is lol :slight_smile: I know just enough to get in trouble. I have it all running.

I believe it is:

sudo npm install -g cncjs@latest --unsafe-perm

But I have not tested that. At least not recently, that I can remember. If that command works, then sudo reboot to start the new version.

1 Like