Cant change y acceleration in Marlin?

HI, I am using a skr1.4 and two 5160 drivers to make a simply two axis cnc lathe, when I adjust the acceleration values, with M204 t (travel values), it changes the acceleration of the x axis, but not the y axis. The Y axis just revs up to high acceleration, grinds and misses steps. I have also tried to use a M201 Y 1 and it doesnt affect anything. I am pretty sure this is a software issue, I have tried switching drivers, stepper motors, and they all are the same on the Y axis with or with out any load, so it has to be something with marlin not changing the Y acceleration values. Anyone know what might be blocking the adjustment to the Y acceleration values?

What version of Marlin are you using?

M503 dumps most settings from the firmware. You should be able to see if your changes are being made.

Additionally, changing those doesn’t “save” the changes through a reboot. You also have to do M500 to save them to EEPROM, which will be read first when resetting the controller.

I’m not an expert here, but…

If the value you are using for M204 (starting acceleration) is greater than the configured Maximum Acceleration (M201), then it probably won’t take effect.

Yes, I have been running M500 after changing, and if I run a M204 it reports back the values, as 1, which effects the X, but not the Y. It is very strange. It has to be something I am not setting up in the firmware from what I can tell.

it happens even when I set these settings through a fireware build also, and it reports back the corrected settings, but it doesnt effect the y axis.

Can you paste in what you have from M503? 1 sounds way too small for accelerations. That makes me wonder about the rest of your units. But maybe we can spot something anyway.

Looks like this is version, I got it from the bigtreetech github for the 1.4 board. //#define SHORT_BUILD_VERSION “”
Here is my M503

Am I reading that right? Max feedrate for y is 1? Could that be limiting what it will allow acceleration to be set at? Might try changing that first.

Disclaimer I’m definitely no marlin guru by any means just taking a stab at it

yes, I just set that to 1 and it did slow down the y axis to where it is not rev’ing up but if I change it to 2 it revs, grinds and misses steps. I am also getting some vibration and sound when the motors are moving faster than a crawl.

I am wondering about the M205, I dont know what exactly they do but they are all at 0? I dont remember changing these values.

If i’m not mistaken those numbers are in mm/m. So at 1 you wont be really moving at all, yes it is but nothing you’ll ever be able to see. even at 2 I don’t think you could ever see it. Are you sure that you have good connections for your motors to the board? What you are describing sounds like only one coil is getting power or its losing connection when it tries to move. Even at 2 mm/s you shouldnt be skipping any steps at all.

Hmmm. M92 looks a bit funky. I assume you have a good reason to have X and Y set to 388 and 610. Some kind of leadscrew setup? Does the machine move 10mm when you command a 10mm move on these axis? Do the axis move freely on their own (do you just need some grease)?

610 is quite a few steps per mm. So you probably have a lot of torque and not a lot of speed. Our Z steps per mm is 400 for 1/16th microstepping and 800 for 1/32nd. That still requires a lot slower movement than X or Y. Steppers have a weird relationship with speed. When they are at higher RPMs, they produce more backwards voltage, and if you power supply isn’t a high enough voltage, they can saturate. In saturation, they don’t get as much current as the set point, and they can skip steps. Getting the right ratio of motor spinning to speed is key, and yours looks pretty high. Slowing down the Y axis should be solving it though, which is what you’re doing, and Marlin isn’t listening.

Does it seem like the maximum feedrate of 1 is being respected? i.e. once it gets up to speed, does it move only 1mm every second, or take a minute to move 60mm?

I don’t trust M204. That is in mm/s/s, but I don’t know when it actually respects that. I would set that to 10,000 and just use M201. M201 is also mm/s/s, so anything under 50 should be pretty noticeable.

Those are definitely suspicious. I don’t usually change those. Our firmware is tuned for our machines and we enable JUNCTION_DEVIATION. That might be messing you up. It might be considering anything from 0 to 1mm/s as an instant move. Switching that off in the firmware and adjusting the JERK settings might be a better option for your machine. The B,S,T settings are also suspect, but I don’t have time to research them right now.

I am mostly worried that it doesn’t treat 1mm correctly. To test that, you could make your Y steps per mm 61, and then move all the M201/M203 up by 10x and just make sure it is respecting those acceleration values. Then go back and see if we can figure out why it isn’t respecting those values close to 1.

But also, you don’t want to live with a CNC machine that can only move 1mm/s in Y, right? That’s really slow, right? Or is this some kind of special machine that makes that tolerable?

Yes, it is a leadscrew type (basically a slideway for a metal lathe) so slower movements is good and not a problem as I am only cutting profile of pool cues, so I will be making a few passes along the x axis and the y will only move a small amount to adjust for the slight taper. The Y axis takes a lot of revolutions to move a small amount, which might be the actual problem. So only moving the Y 1mm currently works, but when I try to move it 10mm or home the machine is when I am getting the problem, as it seems to accelerate too fast. With the x axis I am able to slow it down so it will wind up slowly and moves smooth.
I have the m92 steps per axis set now to make it move the correct distances, I already have the micro stepping to 0 on my Y axis to get the number down to where it is. It was over 9000 steps per mm at 1/16 microstepping. My x axis takes more torque and it is working at 1/16 and 388 steps/mm. I might have to change my pulley sizes to reduce the Y steps/mm, as I already have the microstepping down to 0.

I am going to try to move the 204 values back up and see if I can get them to work with the m201 to see if it is more noticeable at a lower steps/mm. If not I can also try to start over with a different version of marlin and see if that changes anything.

OK, I think you guys have talked me through the problem, I switch some pulleys around and which slowed down the speed of the stepper and it is working much better. Acceleration was not the problem, I moved those values up but still have my M203 speeds low and it is moving as I would like. Thank you for your help.