Cannot Connect to Repetier Host

I contacted the forms about some end stop troubles and needed to run a command but it seemed at the time that I needed to add on some software that wasnt previously there, so I put some on or tried to with a 1.8.5 Arduino board and then the Rambo couldnt connect so now I am trying it again with a different kind of firmware then what I need and now arduino is giving me a “Error compiling for board RAMBo” when I try to put on firmware. What should I do?

I’m not clear on what you are asking, repetier and arduino have nothing to do with each other.

If you are trying to flash your board,, You have to use 1.8.9 or higher shown in red.

I have tried to flash my board, but I did it with the wrong kind of Arduino. And I am getting errors saying that it will not compile when I try to upload the firmware. I intially did it with 1.8.5 but now I am re uploading it with 1.8.9 and I am getting compiling errors (and the board that use to be able to connect with repetier host now no longer does and that only changed when I started to add in firm ware via arduino)

Close repetier, it is not needed until after you flash. Restart your computer. Download a fresh copy of my firmware, unzip it, try to flash again using arduino 1.8.9. If you get another error I need to see it.


Ok this is the Error I got copied and pasted from Ardunio IDE 1.8.9


Arduino: 1.8.9 (Windows Store (Windows 10), Board: “RAMBo”

sketch\src\lcd\dogm\u8g_dev_st7920_128x64_HAL.cpp: In function ‘uint8_t u8g_dev_st7920_128x64_HAL_fn(u8g_t*, u8g_dev_t*, uint8_t, void*)’:

sketch\src\lcd\dogm\u8g_dev_st7920_128x64_HAL.cpp:111:29: error: ‘U8G_SPI_CLK_CYCLE_400NS’ was not declared in this scope

u8g_InitCom(u8g, dev, U8G_SPI_CLK_CYCLE_400NS);


sketch\src\lcd\dogm\u8g_dev_st7920_128x64_HAL.cpp: In function ‘uint8_t u8g_dev_st7920_128x64_HAL_4x_fn(u8g_t*, u8g_dev_t*, uint8_t, void*)’:

sketch\src\lcd\dogm\u8g_dev_st7920_128x64_HAL.cpp:154:29: error: ‘U8G_SPI_CLK_CYCLE_400NS’ was not declared in this scope

u8g_InitCom(u8g, dev, U8G_SPI_CLK_CYCLE_400NS);


exit status 1
Error compiling for board RAMBo.

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

Do not use the windows arduino app, use the real Arduino download, Follow the instructions I have laid out every single step, you are missing the LCD package.

Please, use 1 thread, spreading this over multiple threads is extremely difficult for me to follow. Pick one and only reply there.

1 Like

ok I got it to work now, thanks. Do I need to start a new thread on end stop switch trouble shooting?

Might as well stay here or your switchg thread.

Start with what m119 currently says, what you want to happen, and are you sure you want endstops…they are complicated. We did not use them for years.

I have ran the M119 commands encountered a problem talked it over with my brother and did some testing. Two of switches on the min side for both X and Y are tripped and remained tripped even if we switch out wire to different switches or disconnect the wires entirely from the X and Y min. We thinks this is a board issue. (We still get x and y triggered even if we unplug the x an y wires from the board). And yeah unfortunately for me I am doing the endstops.

What does m119 say?

If you popped both pins, you can use others on the board, but you need to be careful as it sounds like you plugged them into power and signal instead of ground and signal. They are different on the min and max side. To use other pins you will need to re-flash and edit the pins.h for your board and remap those two signal pins.

You do not have to use endstops, you can always reflash and not use them.

Ok I have just relfashed to board for to not need to use endstops, my problem was is in Repetier I cannot seem to find a button to reset whatever cords the gantry is in (except to use E-stop to reset the postion as home and use it)

Just issue a G92 X0 Y0 Z0 or add it as a macro button.