Can’t load firmware

Hi im almost done building the LR3 im at the point where I want to update the firmware.

I put the files on the SD card but when I boot the board nothing happens there are three red lights and one blue light shining bright but nothing turns green nor does the file change name.

I formated my card both exfat and fat32 on mac its a 64gb card but I don’t see how i can format it to 32. Any help would be greatly appreciated. I’ve searched the forums but can’t find an answer.

You need a partition manager to force a FAT32 format on a 64G card - other than that try a sub 32G card formatted to FAT32.

I sometimes despair at modern societies push for ever greater capacities, you will never in a month of Sundays fill an 8G card with gcode files but you try buying one now, no, you have to buy a 1TB card because that is all that is available (ok…maybe a little exaggeration)

Yeah I’ve tried buying on smaller than 64gb but I couldn’t find any.

Diskutil on Mac usually lets you format and partition the disks but I can only format it. Maybe if I first format it to a different format and than portion it to 32gb and reformat it to exfat. I’ll try that.

Helpful info from the FluidNC documentation:

I haven’t had good luck with cards above 32Gb. Several I tried just wouldn’t work reliably for me, and they tended to all be higher speed cards as well.

1 Like

OK… I don’t do mac’s so I accept that may well be different BUT…Windows has a 32GB limit on partition size for fat32. You can get around it with external software to partition the card down to 32GB but the STANDARD tools from within windows won’t work and I would be nervous about advising people, whose IT skills are unknown to me, to go messing around with a partition manager…sooner or later someone will partition their system drive.

1 Like

I have a solution for you…look on Aliexpress for a 1TB microsd card for $2… I can pretty much guarantee it will be under 8gb actual size with a dodgy bootloader that declares it to be 1TB.

(only kidding!)

1 Like

haha yeah it could probably be 1mb too.

all kidding aside I found an old 2gb micros laying about, I think it worked altho ive not seen any green lights. but the file is renamed.

I’m having this same problem.
I have an 1GB microsd, I’ve formatted it as FAT32, 4096 bytes allocation unit.
The board lights 3 orange lights, a blue light when there’s a card in the reader, and nothing else. No green light or whatsoever. I don’t see it rename the firmware.bin file.
Please help.

For me the solution was the smaller size SD card

On Mac I also had to go into the diskmanager and make sure to select the main partition not a sub partition

I use windows.
Tried some old sdcards here but none worked.
Bought this card from China, It might be missing its bootloader. I’ll try rewriting it, but I need a tool for this, I’ll have to wait for it to arrive…

Maybe a typo, but you don’t want to format to exfat. FAT32 only.

1 Like

There are tools you can download to rewrite a bootloader or am I missing something?

We may be talking about slightly different things.
There’s a bootloader on the microcontroller that runs the various print control boards. That generally does not need to be replaced, and when it does it usually needs USB or JTAG or other programming method.

On a (micro)SD card, there’s a file system, and although you can put bootloaders on the filesystem to boot OS like raspberry Pi OS, again that’s not what we’ve been discussing here.

For an SD Card, if it isn’t in the correct file system format, you’d need to use a tool to wipe the existing filesystem and then create a new one.

For an SKR series board, the file system on the microSD card has to be FAT32. EXFAT is a similarly named extended filesystem used by Windows machines for large capacity storage. The embedded software on the SKR doesn’t understand how to read that fileystem.

On my MacBooks, I’ve had trouble using disk utility to do what I want if I have a large device. It has worked better for me to just put the card into one of my Linux machines and use Gparted to do the work.

If the card is 32Gb or less, this works for me:

Connect the memory card to the Macbook.
Open Disk Utility 
Select the SD Card.
Click Erase.
Enter a name for the SD Card.
Choose File System: If the card is if it’s 32GB or smaller, choose FAT32.
Click Erase.

@MakerJim understood that, and I think me typing exfat was a typo.

I got mine working weeks ago.

I was responding to @Edson_Ishi who said he ordered something to rewrite a bootloader.

Sorry for not replying earlyer. I ordered the tool for rewriting the board bootloader and I’m waiting eargerly to test it. I’m currently away from home, I won’t be trying it until friday the earlyest.
The one I bought is called ST-link or something like that. Saw a video about it on youtube.
It’s a usb device that connect a computer to a serial port on the SKR PRO.
It supposedly can write a bootloader to the SKR even if it’s corrupted or non-existent. You write straight to the memory, completely independent of the processor, I think.
When I try it I’ll post the result.

1 Like

Hope it goes well, keep us posted!

Sorry again for the delay to reply.
Well, the ST-Link arrived and I followed the youtube video (forgot to put the link to it earlyer, I’ll put it below).
Pretty easy steps, but you’re messing with 5 wires that connect the usb dongle to the SKR PRO. They are labelled in the device itself and the board, so they are easy to setup.
And I made the damn green light flash!
What I thought was’t clear on the video is that this procedure only writes the bootloader, nothing else. So when you write the bootloader, no green light flashes.
It seems the guy on the video already had his SD card plugged when he did the procedure. I didn’t.
After I finished the writing the bootloader, I turned off the board, hooked the screen and tried to turn it on, but nothing showed up.
Then I turned it off again, put the SD card with the firmware in it and turn it on again, this time the damn green light flashed for a few seconds. The next time I booted the SKR I was able to see the board seems to be working as it displays information in Marlin Mode.
This challenge was conquered, now there are many more, but I’ll let that for another time.
In short, once you get the ST-Link (can be bought in Amazon, ebay…) everything else is a breeze. But you still need the firmware flashed to a micro SD card.

This is the link to the video I followed:

1 Like

Glad it all worked out