Bed heating but thermistor not reading correctly

I am in t2 but i tried t1 also. When I press print the bed starts heating but the temp does not change on the lcd. After a few minutes I get a temp failure. The temp on the lcd reads 22 degrees c. It is the mk3 al heated bed. mp3dp MRambo 16t aero

If you unplug it, does it go to something odd, like -26C? Did you configure the firmware? Is the thermistor set right? The mpcnc firmware sets it to a dummy value.

Which controller are you using? On Ramps and ramps compatible boards T1 is bed, T0 is E0, T2 is E1. Makes sense, right? Pinout is here. Extruder thermistor should be in the socket closest to the endstops, bed in the middle.

Also make sure you have incoming DC to both pairs of sockets marked A and B.

Hey Jeff Are you on the v1 payroll? Good idea! So if I unplug the bed thermistor nothing changes. If I unplug the extuder it goes to 22 and when I plug the extruder into the bed plug it reads the same as if it is plugged into its own plug 26. i think im going to plug both extruder and extruder thermistor into the bed and see what happens

1 Like

I am using the big one that v1 sells.

Do you have a multimeter? You can test if a thermistor is working properly by measuring the resistance. At room temperature it should be about 100k ohm.

ok ill check the ohms.

The bed plugs work for the extruder.

125000 ohm for the bed thermistor and 110000 for the extruder thermistor

Who flashed the firmware? I think the configuration is wrong.

I flashed it twice. I think it is the thermistor.

I am going to flash it again.

Are you saying that I should use a number other then 11? I went through the list and didn’t see anything that would match better.

  • 11 : 100k beta 3950 1% thermistor (4.7k pullup)

You should use one that matches what you have. 11 is in all the cheap clones, IIRC. If this is a prusa bed, can you see what they set it to?

It is the heated bed off the v1 store. Im using the settings that are recommended on their web pages. But for the heated bed it says “usually to 11” I know my extruder temps work on these plugs.

in the firmware it is set to 11 out of the box. no changes needed

then everything else is setup in repetier host

:+1: I misread your original post.

Installed a new thermistor Problem solved. Thanks all