Bad Board or Firmware Maybe?

So, I got my primo with dual endstops all wired and everything works as it should except when I am trying to home the Y axis. Y1 will touch off the endstop and move in slowly and stop but Y2 will sometimes not stop at all or will touch off move in slowly and not stop. I have tested the switch with a meter and it’s working also the red light comes on the board when it’s triggerd. Is there some setting I need to look at? I am a complete newbie when it comes to marlin but I can follow instructions so any help would be appreciated. I bought the kit from V1 with the SKR Pro 1.2 and TFT 35 screen.
It did home a couple of times out of hundred so I took advantage and did the crown test. What an amazing expierience to see it come to life!

Are you sure the Y1 switch matches up with the Y1 motor?

Yes I trippled checked.

Sorry - that’s the limit of my available suggestions. I’m not using dual endstops, that board, or the V1 Marlin firmware myself, but have seen that as a common cause for this issue here on the forums.

On my grbl setup, I had issues with EMI noise on the end stop connections, which I solved by slipping capacitors between the signal and ground pins at the board, but I don’t think other folks have been having that issue with the boards sold through the V1 shop.

Someone else with applicable experience should be along soon.

Only other thought is an intermittent connection. If it did work once, then logically all the parts are in the right place. Any chance a connector is flexing during that homing sequence?

That’s what I originally thought but when it occurs I look at the board and the light is triggered. I even manually moved the truck back and the light goes off then back on when the truck hits the endstop again. It’s like the motor just isn’t getting the message to stop.

This sounds like the problem we have been seeing with the SKR Pro and endstops. The first discussion was here, and there have been other topics opened on the forum with this same issue.

If it is the same problem, the solution is to either 1) cut the trace to the endstop LEDs, or 2) Add a pullup resistor to the sensor pin for each end stop.

1 Like

My endstops don’t have LEDs, I got them from V1. The led is on the SKR board next to the motor pins.

I’m sorry, when you say cut the trace do you mean on the board?

I use the term “cut the trace” figuratively. Since I did not personally do the job, I’m not sure what is involved or the best way to do it. You need to somehow disconnect the LEDs used by the endstops.

My hobbyist understanding of the issue is that the signal pin is not getting pulled high enough to be considered “HIGH” with some boards. This is a recent problem, probably related to a particular batch of SKR Pro boards and some out-of-spec components. So, the solution is to either add a second resistor that pulls the signal pin higher and therefore is recognized as “HIGH” by the firmware, or to somehow disconnect the LED, so they no longer divide the voltage and pull it down. According to what I read on the forum, both solutions solve the problem.

1 Like

Ok, so I was playing around and decided to physically move the endstop blocks in or closer to the X1 rail and now it seems to work?? Any idea why this would do it? Is there any procedure to setting up the endstop blocks? I just put them equal distant from their respective corners as close to home position as the machine would allow plus a little “breathing room” Now I have zero “breathing room” but it works!

1 Like

I’m glad the endstops are now working. As for placement, I’ve seen any kind of “official” stance, but I can give you my personal ideas. I placed my endstops as close to the corner as I could and still have them trigger.

There are two reasons for this placement. First, it maximizes my working area. Second, it protects my machine. If you use your machine like 99.9% of owners, soft stops will not be enabled during cutting. Sooner or later you will make a mistake that will cause your machine to drive into X min or Y min. The way I’ve placed my endstops, the core hits the trucks before the levers are even fully depressed. This limits the amout of mashing my machine will do, protecting the switches and the stop blocks.

Frustratingly there’s an SKR board design issue some people are encountering Search results for 'SKR Endstop pullup resistor' - V1 Engineering Forum where even though the controller board’s endstop LEDs light up, the Mcu still doesn’t think the Endstops have triggered. M119 tells you what Marlin/Controller actually thinks (regardless of board LED status). If you’re seeing a mismatch between M119 output and the endstop LED then the pullup resistor trick mentioned in search results may help.

Link in @robertbu post has more precise details than I’m able to articulate. Hope that helps still.

1 Like

Curious what gauge wire you’re using for your Endstop wiring?

Thank you for all the info! If I have any more issue with them at least I know now where to start looking.

It is the wire supplied with the kit that has a plug for the motor and one for the endstop.

I would edit the circuit even if I had an SKR that never exhibited the issue, because there’s a good chance someday it will. As is, that circuit is going to deliver just shy of 2V to the MCU in the high state. That voltage is already right on the redline, and it will vary with temperature and age. There are ways their engineers could have added input LEDs without introducing this problem. They got pretty lucky with how the numbers shook out on this one IMHO.