Archim2 trouble flashing Marlin

This has been a journey! I also am having a little trouble compiling and uploading. I have an Archim 2.2b board and this is what I’ve done so far:

  1. Plugged in the steppers and end stops.

  2. Downloaded MPCNC_Archim2_T8_16T_LCD_16step and tried to install using a Due as the “board” (I was young and naive)

  3. Received compiler errors for missing libraries (TMCStepper and U8glib). Fixed those by installing those libraries.

  4. Dug deep, read the docs, and configured Marlin for dual end stops (pins_archim2, config and config_adv attached)

  5. Installed “Archim” board by copying the following into the “additional boards manager URL”:

  6. Tried uploading using the “archim” board. Received a “Very Successful” error (picture in the first attachment). It was the most successful error I’ve had yet with the Archim 2.

  7. Based on whoever’s suggestion that a “manual erase” followed by a re-flash would solve this problem: I then held the “erase” button whilst pressing “reset”.

  8. Now I can’t get my computers (windows and linux) to recognize the board. I cant read/write to the serial port (obviously, because I presumably erased any program on the board) and I can not get a “very successful” error anymore. All I get is whats illustrated in the second attachment. It should be noted that I can see /dev/ttyACM0 appear/disappear when I plug/unplug. From my windows machine, I get a “driver not working” error.

  9. I tried pressing “reset” right when it started uploading to the board, but that did not help. It just caused the upload to “hang”.

Any help would be appreciated. I’m thinking this is going to be a winner of a board once I get it working.

Configuration.h (82.2 KB)

Configuration_adv.h (99 KB)

pins_ARCHIM2.h (7.5 KB)

For now, you will need to use the firmware I have directly linked from my dropbox on the firmware page, use that as a base and make all the changes for the ARchim2.

I do not have a 2 to know how those drivers all need to be set.

Ill try to upload tonight using the specific firmware you posted. But since my computer wont recognize the board anymore, I’m skeptical. I reached out to ultimachine. It seems like a bootloader issue to me, but idk I’ve never programmed a due/arm.