Another TMC5160 Issue

Hello all, I have recently followed TeachingTech’s tutorial to build the MPCNC using the TMC5160 and the SKR V1.3… and well it isn’t working. I built the whole thing, wired it up and when I loaded the firmware (I have tried compiling my own firmware from TeachingTech’s video, I even tried downloading BigTreeTechs Marlin and start from scratch, and I tried the firmware from here) and I keep getting the error

Testing X connection... Error: All LOW

on the TFT screen. I’ve tried bending out the CLK pin, I’ve tried grounding the CLK pin on the X TMC5160 driver also with no luck.

I have seen comments on here where people say the TMC5160’s are difficult and where people have switched to the TMC2209’s and have worked. I am on day 4 of this struggle and this is my last ditch effort in hopes I do not have to buy $40 more worth of parts…

Is there anything that I haven’t listed that I should try? Appreciate any help I can get!

Do you have the jumpers set right for the spi connection? If you got it flashed, then you’re doing all right.

BTW, I’m going to move this to the skr category, take a look through some of the other topics there.

Yes, the RED pins are jumped together. Here is a photo with one of the drivers taken off to show the jumpers.

I will definitely take a look around in this category!

Have you seen this video? The same can help you:

I looked over the video, I snipped all the CLK pins and soldered a wire between GND and that pin.

I also ran M122:

	         X	      Y	     Y2	      Z      Z2
Enabled		false	false	false	false	false
Set current	800 	800 	800 	 800	800
RMS current	792 	792 	792 	792 	792
MAX current	1117	1117	1117	1117	1117
Run current	15/31	15/31	15/31	15/31	15/31
Hold current	7/31	7/31	7/31	7/31	7/31
Global scaler	133/256	133/256	133/256	133/256	133/256
CS actual		0/31	0/31	0/31	0/31	0/31
PWM scale	0	0	0	0	0
stealthChop	false	false	false	false	false
msteps		256	256	256	256	256
tstep		0	0	0	0	0
threshold		79	79	79	658	658
[mm/s]		800.63	800.63	800.63	24.03	24.03
OT prewarn	false	false	false	false	false
OT prewarn has
been triggered	false	false	false	false	false
off time		0	0	0	0	0
blank time	16	16	16	16	16
-end		-3	-3	-3	-3	-3
-start		1	1	1	1	1
Stallguard thrs	0	0	0	0	0
sg_result		0	0	0	0	0
Driver registers:
	X	0x00:00:00:00	 Bad response!
	Y	0x00:00:00:00	 Bad response!
	Y2	0x00:00:00:00	 Bad response!
	Z	0x00:00:00:00	 Bad response!
	Z2	0x00:00:00:00	 Bad response!
Testing X connection... Error: All LOW
Testing Y connection... Error: All LOW
Testing Y2 connection... Error: All LOW
Testing Z connection... Error: All LOW
Testing Z2 connection... Error: All LOW

I am getting no response at all from the drivers. I ran the precompiled firmware I found here. I have as of now tried the following:

  • Snip CLK Pin
  • Solder wire between GND Pin and CLK pin on all drivers
  • All Jumpers are jumping the RED pins (making it SPi)
  • Downloaded pre-compiled firmware and compiled TT’s firmware files WITH the grounded CLK pin, received NO RESPONSE from all firmware.

When I upload the BTT software unedditted (Setting the drivers to TMC5160 and enabled TMC_Debug) and run M122 I receive this:

Driver registers:
	X	0xFF:FF:FF:FF	 Bad response!
	Y	0xFF:FF:FF:FF	 Bad response!
	Z	0xFF:FF:FF:FF	 Bad response!
	E	0xFF:FF:FF:FF	 Bad response!
Testing X connection... Error: All HIGH
Testing Y connection... Error: All HIGH
Testing Z connection... Error: All HIGH
Testing E connection... Error: All HIGH

Could I have a faulty SKR V1.3?

I doubt it is the skr, because there aren’t many problems that would let you run M122, but not get the right result.

The microcontroller seems fine. It is chatting with you.

The PCB is the same as every other build, or at least it is a very low probability that it is the problem. If there was a bad solder to the microcontroller on one of the spi pins, then that would cause an issue.

The jumpers look right to me. But I haven’t looked at the instructions in a while. If even one of them were wrong, they would all be bad.

The drivers are new, and the chance that all 5 are toast is pretty slim. The older TMC2130 drivers had the ability to be put into standalone mode, where they would act just like drv8825s, and ignore the spi pins. There were some little config solder joints underneath them. If you had 5160s that were configured for standalone, that would explain it.

The error is somewhere in there. All the other stuff in the M122 is meaningless, except for:

That is saying there is no communication.

We are getting quite a few issues with the skr boards, and a few people have given up. We don’t see this problem with the rambo. I initially decided it was because the skr was more generic, and there isn’t a preconfigured software for it. But maybe there are some larger issues at play here.

I can confirm it is not the board. Awhile back I upgraded my Ender 3 to Dual Extrusion and I installed the MKS GEN V1.4 with A4988 Drivers. I took a driver from my 3D printer, put it in the X slot, reconfigured it and it works perfectly. It is definitely an issue with the TMC5160. Guess I will have to trade out the TMC5160s for another driver for now. Appreciate the help!

Before you give up, can you try configuring them as drv8825s in Marlin and see how that goes? If they are configured for standalone mode, then they should work in that configuration.

Did you solder a pin in diag1?

I had to take pin 6 out of the way so it does not get connected. I found it online somewhere (Clock )

This has been said a few times. If the SKR 1.3 cannot communicate with the TMC5160s, please check this is uncommented in configuration_adv.h:

#define TMC_USE_SW_SPI

I 've got same issue, all low with skr1.3 and tmc5160. Nothing changes to solve this.
I 've got also a skr 1.4, and no issue on this board, I mean the tmc5160 is working to move the motors, but the dual endstop for dual driver on y or z axis is not working, both motors are stooped.
If I compare the schema electronics between the two boards there are some differences on the connections to clk pins that could explain why this tmc5160 is not able to initialize properly. So I think this is the boards that are not supported tmc5160.

Please note that psu control have no effect for me, also the patch 63 no effect.


I’ve got similar problem with SKR 1.4 Turbo and TMC5160. I’m working on the factory firmware for now.

I’ve got the following answer :

Testing X connection… Error: All HIGH
Testing Y connection… Error: All HIGH
Testing Z connection… Error: All HIGH
Testing E connection… Error: All HIGH
Testing E1 connection… Error: All HIGH

DO I need to upload firmware as suggested in “TMC2209 and TMC 5160: Guide for MKS Gen L and SKR V1.3” to make it work ?