Z resolution

I am almost there. I’m having a problem with Z resolution. I’m still plotting stuff, haven’t installed my spindle yet.

I am using Ramps 1.4, , 5/16 allthread Z screw, Ryan’s MPCNC813 Firmware, controlling with Repetier.

I found a .dxf of a Harley Sign I’m trying to plot. I loaded the .dxf into Estlcam, scaled it to about 200 mm wide, and saved the gcode.

When I run the plot, using a sharpie in the pen holder with the bushing and screw, the Z axis is lifting between plot segments, but each time it puts the pen down, it puts it down farther each time until the sharpie is squeeking or pushed up out of the holder. I think this is due to the Z axis resolution being too high.

Looking at the firmware settings in Repetier, I see that X axis resolution is 100 steps/mm, Y axis resolution is 100 steps/mm, and Z axix resolution is 2650 steps/mm. Is this correct?


What plunge and rapid speeds are you using for the z axis? It should be about 3mm/s and under 8mm/s any faster on all thread and that happens.

Well, it was at 10mm/sec. I lowered it to 3mm/sec. and it’s still happening…


What about your rapids?

I can see by looking at Estlcam, what you are picturing, but unfortunately, I cannot see/read the #'s in your picture… Could you put them in a reply, please?

2100 and 480

It is from this page



and this is the pic


Let me ask a dumb question. If I’m using Estlcam to resize a .dxf file, and create the Gcode, then load the file into Repetier to plot, do I still have to slice it? I ask because I loaded the Harley sign into Estlcam, and when I send it to Repetier, the print preview says it will take 6 hours and the axes move incredibly slow.

No slicing. It sounds like you have not set the rapids if it is moving slowly.

That page with the crown on it is step by step including the repetier part. If you want to go through that and just tell me any part that is unclear I will fix it.

I have finally figured out the resolution issues with my MPCNC. I’m running Ramps 1.4, A4900 drivers. I use F-Engrave to produce G-code from .DXF’s. I use F-Engrave because I’m familiar with it and it is a very simple program.

I do have all 3 jumpers installed under the 3 driver chips.

I was having issues with the Z axis either gaining height as the plot ran, or loosing height and driving the pen into the bed.

I could plot the same file 3 times and get 3 different results. today I discovered that even though the Z has the jumpers set for 16 micro-steps, it was only stepping at 4! Once I figured that out everything is working!

I have been struggling with this since probably August! I couldn’t tell you how many times I re-flashed Marlin, tore down the electronics and started over… Though I was getting good advice here, nothing I tried worked. Today I started by hand calculating the steps/unit rate for Z. No matter how many times I calculated it, or wether I calculated in imperial or metric, I got the same answer and same results. Finally, I measured the z height with a height gage I had made a few years ago from a block of cast iron and a digital caliper. I moved Z up 10mm via Repetier manual control and measured the distance. It was 20 mm.

That lead me to try different micro stepping rates in the steps/unit calculation until Z moved 10mm when I said move 10mm.

I humbly apologize if I upset anyone that tried to help. I was getting so frustrated at nothing working to expose/fix my problem, I almost threw the thing away!

When my head returns to normal size, I’ll post a pic of the plot I made here and on the FB page.

Of course, my next trick will be to mount my spindle and cut something…

A4900 has a max of 16th stepping for all axes. The DRV8825 are the recommended ones and what I assumed you were using, sorry for not checking.