Z motor Skipping (contunued woes)

So I had a successful crown test, thanks to those here who helped. however during the troubleshooting and subsequent projects I have experienced what I think is referred to as “Skipping Steps” in my x- or left hand Z motor. My motors are wired in series with the wiring harness that came with the Full Kit from Ryan.

This started when I accidentally touched Z+ button twice on the touchscreen when set to 10 mm. the motor tries to go too fast and makes a grinding noise. but now I also got it on my first attempt to do some milling in foam. the axis goes down fine, but when trying to go back up, the left one grinds and the x axis becomes slanted.

Secondarily, I have now realized that the z axis is not going up a full 10 mm when jogging up on the touchscreen.

Lowrider 2, all parts bought from the shop.
SKR Pro with TFT screen
gcode generated with Estlcam 11

1 Like

Does it skip steps in the test crown?

It should always move 10mm for a 10mm command. So we need to figure that out first. If it doesn’t skip, it should be 10mm. How far off is it?

Can you double check the grub screws on the couplers are tight?

Double check the wiring.

I could not detect any skipping on the test crown, it goes up and down, and does not drag the pen on the travels. It only skips when going up really fast, which it does when double tapping the Z+ button, or retracting out of the first hole i ever milled. only the left side motor, and I’ve switched them in the wiring.

It looks like a consistent 5mm raised when i raise it 10, even when not skipping. x and y are dead on 10 mm in travel.

Grub Screws on the couplers are snug, and I used blue locktite.

Make sure you are not moving more than 15mm/s in the Z direction preferably less.

Also, make sure your Z leadscrews are rotating freely, lubed and the nut is slightly loose. Several people have assembled the XZ mains backwards and it causes binding. If you include build pictures we can verify.

Not sure how to check the Z movement speed, using the lcd to do everything. Both Z screws are lubed and smooth I can raise or lower the axis by hand by twisting the coupler on both sides, though it is tougher on the right side, the left side is the one that skips, and the only side that free falls when power is cut.

Nope. That makes no sense :slight_smile:

Can you verify the Z has 400 steps/mm?

M503 will show that, but it is so verbose, you need to run it from a computer. I think the screen settings can also display that.

I wouldn’t mind a picture of the controller and screen too.

Here’s the board and screen. I’ll have to work on getting a pc over here.

Dunno what I’m looking at, here are the result of the M503 Command:

20:38:44.544 : N23 M503*20
20:38:44.544 : G21 ; Units in mm (mm)
20:38:44.544 : M149 C ; Units in Celsius
20:38:44.544 : M200 D3.00
20:38:44.544 : M200 T1 D3.00
20:38:44.544 : M200 T2 D3.00
20:38:44.544 : M200 D0
20:38:44.544 : M92 X80.00 Y80.00 Z80.00 E80.00
20:38:44.544 : M203 X300.00 Y300.00 Z300.00 E300.00
20:38:44.544 : M201 X3000.00 Y3000.00 Z100.00 E10000.00
20:38:44.544 : M204 P3000.00 R3000.00 T3000.00
20:38:44.544 : M205 B20000.00 S0.00 T0.00 X10.00 Y10.00 Z0.30 E5.00
20:38:44.544 : M206 X0.00 Y0.00 Z0.00
20:38:44.544 : M218 T1 X0.00 Y0.00 Z0.000
20:38:44.544 : M218 T2 X0.00 Y0.00 Z0.000
20:38:44.544 : M145 S0 H180 B70 F0
20:38:44.544 : M145 S1 H240 B110 F0
20:38:44.544 : M301 E0 P22.20 I1.08 D114.00
20:38:44.544 : M301 E1 P22.20 I1.08 D114.00
20:38:44.559 : M301 E2 P22.20 I1.08 D114.00
20:38:44.559 : Z2.00

Gotta say, running it via repetier host it’s a lot slower/smoother. Still seems to run about 5 vs 10 Z mm.

Dunno if this is relevant or not, but I am able to twist both Z couplers by hand even with the motors engaged, it resists, and clicks, but its not very difficult.

That really sounds like a grub screw problem. You should not be able to turn those z couplers if the motor is engaged. Did you use a locktite-type thread compound? Did you lock to the “flat of the shaft” before tightening the second grub screw? When connecting to the threaded rod, did you orient the grub screws so that they touch on the “flat” of the acme thread and not in the groove? These ideas are all in the instructions, but sometimes you think you’ve got is all lined up and it moves while you’re tightening the grub screws.


The Grub Screws are meticulously tightened and Locktited in with blue locktite. The Flats went down first and then the round sides, and the lead screw side is on the thread, not in the groove. The thing clicks when I turn it because it is snapping to the nearest step position, not because of a mechanical interface. I agree that I didn’t expect to be able to turn it while the motors are holding, that’s why i mentioned it here.

The Z should be 400. But that makes rhe physical issues even more perplexing.

M92 Z400

Test jogging again of 10mm

(This saves it).

It also looks like that is not the V1 firmware on the screen. I am pretty sure it shouldn’t show the temps on it.

1 Like

ok I was considering flashing it with the official firmware, I will do so when I get home this late evening.

It is best to use the Marlin side of that LCD. Hold the knob down to go to the Marlin side, that is to use our firmware settings, not what they use on the touchscreen side ( it is different feedrates). (after flashing our firmware on it).

The other thing to look at is the Z tubes, are they the same distance apart top and bottom when you take the carriage completely off. The one picture I can see of the part looks to be tighter on the top than the bottom, that can make it much harder to go up than down.

Ok then, flashed new firmware on both controller and screen, completely different experience. Just tested it and I’m not getting any skipping on the same program i ran before. movement is all sorts of smoother in all directions, z goes up 10 mm per 10.

The marlin side of the screen was not really useable when i first set it up, and I guess that would have been a good indicator that something was up with the firmware.

Z tubes are parallel, My phone camera is just over dramatic.

Thanks for the help guys, I’m calling this one solved.