Z homing failed

I have a problem with Z min. Everything looks functional. M119 reports from min open when I manually switch from min it says M119 triggered. As soon as I give G28, x and y are fine, but the Z axis goes down and won’t stop. Marlin 2.1.1

The Z axis is looking for hte touch plate connected to the Z_MIN end stop port. The ground pin should go to the clip, which should be attached to the tool, and the signal pin should go tot he touch plate. When the two touch, it should stop the Z axis from going down

You can also just home the X and Y axes using G28 XY

Yes, all this is fulfilled. The pick-up plate is connected to the cutter, but the z-axis still pushes into the pick-up plate when touched.

I would look for an intermittent wiring issue of some sort. Some things to try:

  • Put your router at its highest position. Hold the touch plate in one hand and the clip in another. Start homing Z, then touch the plate and clip together. Does the router stop?
  • Unplug your touch plate from the control board, put an ohm meter on the connection. Attach the clip to the plate. Manipulate the wire, especially at the connection points, and see if anything causes the resistance to rise.
  • Put your router at its highest position. Attach the clip to the bit. Hold the plate in your hand. Start homing, and touch the plate to the bit. Does the router stop?

It is remotely possible this is an electronic noise issue, but I would exhaust other test first before taking any action wrt electronic noise. There is a known issue with the endstops on some SKR Pro boards, but I would not expect this behavior from that issue.

Thank you. Of course, all these tests have been tried, but without any positive results.

Check the stop and probe status with M119

With the touch plate and the clip touching, it should report that the Z probe is triggered. If it does not, then there is probably something wrong with the wiring. The touch plate is the least sensitive to noise since it is configured as a normally open switch, and noise would result in a false positive.

Everything looks fine on the M119.

Which firmware do you have, exactly? Something like 515D?

And what controller? Rambo? Skr Pro? Skr Something Else?

Yes I have 515S

Ramps S12

515S is the series wiring firmware. It has only 3 motor drivers active and depends on you to wire the motors on series.

You want 515D for the Primo or 515DL for the LowRider.

“fine” doesn’t really describe it.

You should get something like the following:

> M119
Reporting endstop status
x_min: open
x2_min: open
y_min: open
y2_min: open
z_probe: open

You should be able to then test the touch plate by touching the clip to the plate and getting a change in the report status

> M119
Reporting endstop status
x_min: open
x2_min: open
y_min: open
y2_min: open
z_probe: TRIGGERED

The series firmware that you are running won’t have x2_min or y2_min stops, because they aren’t defined. I am not sure that it is even configured to use the X and Y stops at all. I never ran the series firmware at all, but it should have the Z probe. It might be labelled as z_min instead of probe.

Marlin homing is pretty simple. If your motors are turning the right way, and the open/triggered status is right, then it will work every time. There really isn’t anything else.

Some possibilities:

  • The setup you used to test M119 is different than the setup when homing. For example, you might not have had the router plugged in when testing M119. When you plug it in, it touches ground, and it is immediately triggered
  • The result of M119 is intermittent. Maybe there is a wire coming loose, or some electrical components that are incorrect. Maybe it shows triggered when you have a computer connected, but not when you try to home.
  • Have you confirmed that the Z motor drives the right way when not homing?

If the Z is moving the right way, and the endstops are correctly triggering, then homing works. That equation has solved every endstop issue so far.

It is possible you have discovered a new bug. Not many people are using ramps with serial anymore. Fewer still are using endstops with serial firmware. Maybe you have found a bug we just haven’t discovered yet.