Z decides to reverse mid cut

I built my primo when it first came out a few years ago. Ive cut alot of things with it, but the last month its been reversing the z(downis up, up is down) ive seen the machine do it, but it reversed on a downwards cut so it was far off the surface trying to cut doing no damage. Ive had several times that it has slammed into my material and mess it up like this.

Skr 1.4 board
Tmc2209 drivers

Ive tried messing with the z motor wire while moving the z axis and it hasnt went the wrong way while doing that.

Any one have any idea? Stepper driver maybe?

I think your Gcode / cam is messed up. If you Z speeds are too far off, things can go wrong like this.

1 Like

That was my first thought as well i checked the gcode there was no z below 1mm and i use estlcam with all the settings you suggest. Ive had this issue happen before and i ran the exact file a second and third time without it happening

Actually i just checked. My z is set to 5mm instead of 3 and one more thing my z leadscrew is 1/1 rather than 1/4 so my steps/mm is 4x more than regular.

Could this be it. Im super frustrated. I already spent hours working on that board and to have to redo the whole thing kills me

Nothing to do with distance, speed, plunge speed and rapid speed.

This reinforces what I am saying, you have cut your max speed by a factor of 4. So limit your speed to 20mm/s for rapids and plunges and see if that fixes it.

1 Like

Your talking about the z plunge feedrate?
Im pretty sure its at 5mm/s

Not just Z plunge but also the Rapid feed Z:

Mine is 3000 mm/min which is pretty fast (I am running at 24V). With a 2 mm per revolution leadscrew your Z motor will have to spin 4x faster, so you need to drop this by 4x to keep the Z motor speeds within a reasonable range.

1 Like

Yea mine is at 480 as per the setup instructions on this site

1 Like

I would think that should be slow enough, even with the 2mm leadscrew. 8 mm/second is 4 revolutions per second with your leadscrew, which should be okay.

That could mean it’s maybe a wiring issue giving you lower torque than normal, or something else I can only speculate.


Thanks for the reply

1 Like