Z axis not lifting

Was working through this with a few folks from the Facebook group, but posting over here at Ryan’s recommendation.

Short version -

I keep getting intermittent failures where the Z-axis simply doesn’t go up during a move, causing it to plow right through my material. I can run the same gcode file 2 or 3 times and it will do this at a different point each time, or have no issue at all and have a perfect cut…

Tonight I was cutting some 3/8" pine. 15mm feed rate, 1mm stepdown, 1/8" bit with the DW660, which to me doesn’t seem like it should be very taxing on the Z axis at all.

I’m using Estlcam 10.047 to generate my gcode and printing from SD card. Ramps 1.4, Marlin RC7 (What came with the board purchased from V1). Rapid feed Z is set to 480 and the F(z) for my bit is set to 3mm/sec.

This afternoon I replaced the pineapple connector which appeared to have been a bit stripped out, but that may simply be from me testing. I also lubricated the threaded rod on the Z axis hoping that will help.

Unless anyone knows of anything else obvious, I’m going to try running a few of the same cuts with Fusion360 and see if there’s a different simply based on Estlcam with it’s CAM settings vs. F360 and the postprocessor there and see if I have the same issue there.


No other mods, no anti backlash stuff? Cable chains, vacuum hose? Picture would really help here.

Can you move your z axis with your fingers smoothly from to to bottom with no binding? If you settings are correct the only thing left is physical. Either you are getting your tool catching somewhere, or your screw is binding from bad threads or a tweaked z axis. It should be extremely easy to turn with your fingers. Usually the during the build the rod gets kinda kinked at an angle causing issues. If this is the case take apart the center and redo it, making sure to check the Z axis the whole time.

Try cutting your rapid down to 240-300, this will give your stepper more power.

Next thing you can do is energize your board by moving the Z axis a bit and making sure your driver is set to 0.7V.


I was struggling a bit with this during my build using a T8 and an aluminum coupling, even though the lead screw seemed perfectly straight. The first time I attached the lead screw, it had maybe half an inch of wobble at the end of the rod. What finally worked for me was to slide the lower Z mount all the way down against the tool holder while fastening the coupling to the lead screw. This minimizes how crooked you can fasten it, as the lead screw is supported by the bearing further away from the coupling. I still have a small amount of eccentricity, but it is easy to move the axis up and down by rotating the lead screw by hand.

I am having a similar issue with my build, keep ruining material because the axis will not lift and the toolhead binds. I have tried different materials (plywood, mdf, and pine) slowing down program, shallow depth of cut, created code with both Aspire and Estlcam. Even replaced my Z screw, still doing the same thing. Not sure how to set the rapid to 240-300 to see what happens. Also how would I check that the driver is set to 0.7V by energizing the board by moving the Z axis a bit? Any other advice?

This was 100% of the problems for a very long time. If you have not set your rapids it is the issue. Do not cut any material until you check your gcode, this can be checked by simply cutting above your bed, using a pen first, or cutting High Density foam. No reason to keep wasting material testing software. The only things material would show is skipped XY steps (never happens) or poor GCode for that specific material…

This is the rapids settings,

Found on this page,


Thank you. I am running some of the original/old settings/hardware (my build was done back in Oct 2016). I had the rapid set at 400, I have now reduced the value to 300. I will try a program with this (using foam, as I have some laying around) and see what happens. I am attaching the gcode for the part I am trying to machine, can someone look it over and see if I made any mistakes? Thanks

Insert-mk3_1.gcode (34.4 KB)

It should work as is but it is a little more safe to check the box to have “F” repeat every line.