Y Axis not running straight

Hi there!
I am having some issues with my Y-Axis not running straight down the entire length of my table (4x8 ft. LR2). Here’s what I’ve tried:

  • I have tried to loosen up/tighten everything with no good results
  • I have added a quarter round piece of trim to the Y side to try and keep the wheels from “toeing in”, but the wheel on one side (and not always the same side) end up riding on the trim…
  • My table is completely square - measured from corner to corner with same exact dimensions
  • The width across the long side of the table is exactly the same in 4 different points
  • I added a shim to the belt tensioners to keep the belt from rubbing with the Y tube, but that was only a problem when the gantry was at the 0 or MAX position; regardless, it made the belt straight all throughout from end to end

You’ll see in the video that the Y plates have some sag to them - there is no much weight on them.

I have extra length on my X tubes, but somehow, I can’t seem to be able to get more distance between the two Y sides (so I can have the wheels ride further away from each other); I loosen both ends, but they like to stay in the same position

Here is a video of the issue in action:

These two pictures are the side and top view of the X-MAX side (furthest away from X-ZERO):

These two are from the X-ZERO side:

Here is how I am taking the dimensions of the inside of the frame (to see if my width is the same across the table):

Measurement close to Y-MAX:

Measurement in the middle of the table:

Measurement close to Y-ZERO:

Thanks for the help!

Have you adjusted your carriage so it’s square? IE, if you draw a square with the machine are both diagonals of the square equal?

I believe ur drivers r overheating, causing this, I have tb 6600 drivers on my adma set up and figured, due to size I would not need cooling. I then chased issues around with what seemed like motors comming out of step and though it was RF(plasma) however I should have just cooled like all my previous machines (mpcnc and printers)

@tailslide: I have made successful cuts before. I drew squares and circles that were spot on. I haven’t really tried again since I started having these issues. I will check.

@darxide: I don’t think I am skipping steps. If I measure the distance from the wheels to the end of the table - on either side - both sides are exactly at the same distance at any given time. Occasionally, after one of the sides goes too far up onto the trim, that same side will bind and the stepper starts freaking out, but only due to friction of the wheels against the trim

Sorry, I do not mean skipping steps as that is obvious. On my plasma set up and LRv2 I have independent tb6600 drivers on the y axis. After working for a while one motor would come out of step. Basically it would move less then it’s brother across the table…
And both driven by the same step sir step pul on my bob no missed steps this also happened with my x. On a long but with lots of Pierces x would seem to only move 50% of what it should. I did a lot of work grounding and shielding. In the end the large tb6600 drivers needed cooling. Blows myind the little plug in drivers on my ramps handle load better…

NVM this is not ur problem. I set my y pate to x tube length at the widest part of my table. And right I might add, I use clamps to hold the y plate, and z tubes tight then torque. If ur belt blocks r not square to each other the gantry will bind. Maybe that’s the issue?

I should add I also used 3/4 mdf on the y plates on my router and 2*1/8 aluminum on my plasma with spacers at the bolts totaling 1/2. I deff think 1/2 mdf or birch ply is not adequate.

I checked the belt tension blocks and they are both parallel to each other (same distance from the edge of the table on both sides) and same height horizontally, on both sides of the table.

I am not sure what else to try; short of trying a stiffer Y plate and reprinting my Y assemblies?

Since you already have it somewhat apart you might want to go to 3/4” mdf or even 3/4” Baltic birch plates since like @darxide I also found the half inch mdf plates not stiff enough. Reprinting my Y roller mounts with 95% infill pla seemed to help too.

Also check these outriggers out:


Okay this is a tough one. in order of what I think it could be.

The Round rails are loose enough that the X belt is pulling the axis together. Use a tape measure and see if both ends of the Y plates are the exact same distance apart?

Loose pulley.

The screw tension for the belts is too tight and stopping your Y Steppers occasionally throwing it off.