X wont home anymore

Does anyone have any idea what i could do to get this working right again? The z homes, y homes but x moves right a little. When i home all the z reads 200 and is all the way up, y reads 0 and is all the way forward but x reads 0 and moves right a little from where ever it currently is. I was trying to mess with cutting aluminum and i used G92 X0 Y0 Z0 to home it near the corner of the plate (i still havent figured out the touch plate homing) and that didnt go as planned…so i homes everything to try again and thats when this issue started. I even input M502 then M500 to reset to default (which i will have to relevel the z) and still no change even unplugged with no change. Im lost. Im trying to upload a video of the issue but it wont let me.

I put the videos on the fb group

x reads 0 and moves right a little from where ever it currently is.

This is the behavior if the endstop is already triggered. The little to the right is the retest sequence. Start by checking your endstops with a M119. Assuming the M119 is showing “Triggered,” then your issue will likely be:

  • Break in the wiring
  • Endstop switch wired wrong (needs to be normally closed)
  • Faulty endstop switch (rare but has been seen on the forum)
  • Connected to the wrong place on the control board.

Be aware there is a manufacturing issue seen occasionally with SKR Pro boards that results in inconsistent endstop responses.

The endstop definitely worked fine before this. I cut all 3 strut plates with no issues as well as leveled my z with all endstops working fine. I will check this out tomorrow. Hopefully its something simple.

I just checked it before heading to towk. The x shows triggered and its nowhere near the endstop. What are my options when it was working before?

I list them above. The wiring expects a normally closed connection where the circuit is complete. For some reason, your circuit is broken. Most likely something has been disconnected or you have broken the wiring.

With a multimeter in ohm mode, you can check the continuity of various parts of the circuit. And/or, you can also “short” the connection at various points and test with an M119. You can start with jumpering the connection at the control board and check with M119. Then you can short the connections across the switch and check. Etc.

This is exactly the problem I seem to be having. Just posted a question about this. Will follow this thread as well and let you know if I figure anything out. Worried the SKR board is faulty.

How did you check to see if x is triggered? I have been going by the LED associated with the endstop, but is there something in the TFT commands that can tell me?

There is a problem with some SKR Pro boards wrt endstops. Typically, the symptoms are that the LEDs will light up, but the endstops will not respond (i.e. the machine will continue to move). Typically, the result is seen on multiple axes. I would rule out everything else before assuming the SKR Pro is at fault. There are other reasons why endstops fail. Fully tested the situation with M119 and/or a multimeter. Post back with your symptoms if you are confused.

If the SKR Pro turns out to be the root of the issue, you have three choices:

  • Get a replacement board
  • Disconnect the LEDs (usually involves cutting the traces)
  • Add a pullup resistor to the circuit. Pullup resistors can be added to the wiring, or they can be directly soldered to the control board.

BTW: The root of the SKR Pro issue is that the LED circuit pulls down the voltage of the signal pin so that the board no longer recognizes the pin as being high.

I input the M119 command and it shows the status of the endstops

1 Like

This is counterintuitive. But unplugged means triggered. You need to short the S and Ground pins to have them show up as “open” in M119.

Im sorry i meant unplugged the machine from the outlet

1 Like

You probably just have a broken wire.

I hope not its a brand new build :pensive:…but ill check it out later. I need to break it down anyway for the strut plates install

1 Like

Well i found my issue after installing the strut plates. Even though i taped the x stepper and end stop wires at the extender connectors the endstop connector ended up coming apart which kept the endstop from working. I taped them and looped, zip tied and taped them again lol so hopefully it won’t happen again. Thanks everyone for the help

1 Like

My issue was similarly a loose connection. Crimped a Dupont connector but it kept coming loose. Made it again, taped it and now it seems OK. Lesson learned - can’t check the connections enough.

Physical “layer” is always where I start troubleshooting. If the wire isn’t connected, or is intermittent, no other fixes are going to “stick.” By the same token, when building I’ll work hard to eliminate opportunities for movement, vibration, abrasion, etc. to cause problems with the physical set up of the machine and the wiring. Zip ties, securing connectors, strain relief, extra padding or rounding edges all contribute to a more reliable machine.