Weird difference in firmware from older MPCNC

Got a question for you all… I just had a mega blow on my low rider (my fault) and I have a project that needs done asap, so while waiting for a replacement, I took the mega out of my MPCNC and put it into my low rider.

I’ve been having an issue with the LR where the Z axis will drop if I put even the slightest pressure on top, or something if the router is all the way to one side the weight will cause the Z to drop.

When I tested out my older MPCNC mega, first it was moving WAY faster… like twice as fast, second it was SOLID I pushed down on it to the point that I was worried about parts breaking and could not get the Z to drop. The only issue was the second Z axis wasn’t enabled.

So I assumed my Z drop issues were with my old (burnt up) mega board, and flashed this one with the latest marlin from the github here, and instantly back to Z dropping with the slightest bit of pressure.

Any ideas on if there’s something I’m doing wrong? Or is it just when you run dual Z that’s how it is?

My Z steppers are at 0.85 btw (with a fan). And both the MPCNC and LR use 1/32 stepping with DRV drivers.

My firmware keeps the steppers enabled for 6 minutes after any movement, so either you are turning them off with your gcode or you do not have the latest firmware on your board.

Even with your motors enabled? Or is this when you’re not running gcode?

Was it binding?

In my LR, if the motors are on, I dont think I’ve ever tried to push it down. With them off, it falls under its own weight.

I could see there being a difference in drivers (even if they were set the same, something could be wrong). But I don’t know anything in the firmware that could possibly change the holding torque. When the steppers are set to stay still, the pins are static, and the firmware should be doing absolutely nothing.

So just for clarification, I can push them down when the Z axis is engaged. In fact a few times, with the router fully pushed to one side, it’s been actively trying to raise and that one stepper falls on it’s own then continues moving up as if nothing happened.

There’s also a weird thing where when I touch the stepper driver voltage adjuster with a metal screwdriver I hear voices coming from somewhere :stuck_out_tongue: , either the stepper motor or the fan, didn’t track it down. I assume it’s radio. No idea if it’s related but struck me as weird.

My z motors are not wired together in series or parallel, I started with them in series, but when this problem started happening I wired the Y axis in series and let the second Z run off the E1 port with a different drvier. Didn’t change anything.

And no, with the old MPCNC board it wasn’t binding… it would move just fine using the controls, I just couldn’t touch it and have it drop 2 inches like with the current firmware.

Usually only happens when the leadscrew is binding. But you say nothing on the hardware end has changed. If that is the case there is a problem with your board, firmware, or drivers. If they are running on separate drivers, check the steppers without being connected to the screws, see if one seems weak. There is something wrong, I do have a video with weights on top of my Z there is plenty of strength, That is, depending on what steppers you are using? When your blew your old board are you sure you didn’t damage the wiring as well, or stepper?


Happens to some drivers.




So, the interface to the stepper drivers is this:

  • enable. On when the motors should be engaged.
  • direction. On for one way, off for the other
  • step. Only changes state when the motors are supposed to be moving.

With both firmwares, they are enabled, and not stepping, so the only difference might be the direction.

I’m not sure what the issue is, but I’m convinced it’s not a bug in the firmware. It just doesn’t add up. If you’re sure the physical stuff is fine, then I would take a hard look at the drivers, then the wires and motors. But mostly the drivers.

We had a toaster that would praise Jesus from time to time. KJNP was a local AM Christian radio station about 2 miles from our house. 50,000 watts of religion coming off that antenna. Was weird.

1 Like

I live about a mile from a radio tower… that must be it!

@ryan & @jeff - It was doing it before the board blew. I’m in the middle of converting to the LR2, so I’ll go over all the electronics really well while it’s tore down, but I don’t know of anything off my head except if the far stepper was bad-but-still-working. I’ll definitely check that.

Thanks for the input!

So I was going over my specs, and saw that my steppers are listing 1.7 amps each x 5 = 8.5 amps but my power supply is only 6 amps. Think this might be the cause?

Would that explain why when the firmware that didn’t have both Z’s activated worked amazingly… 4 steppers would be 6.8 amps, much closer?

Nope, convert to watts to see your real usage…and you are not using them at full power. You should be no where near the capacity of your power supply.

alright I’m at my wits end then… First, thanks everyone for chipping in and helping me out here, much appreciated!

I made a video of the problem:


  • down works fine, up only works if I give it a little help and push up on the gantry a bit.
  • when powered off or unplugged the gantry does not fall on it's own
  • stepper can be turned manually by spinning the leadscrew. it's *slightly* harder than I think it should be.
  • both sides (both z steppers) are experiencing the same issue though not to the same degree.
What I've tried:
  • running both Z steppers simultaneously and only one or the other.
  • greasing the leadscrew
  • replacing stepper driver
  • moving the z stepper to X or Y slots (still had the issue but acted slightly differently, my guess is because of different steps / mm)
  • playing around with different variations of tightness in the z/x axis connector to get different z-rod angles
  • playing around with pushing and pulling the leadscrew in different angles to see if that was the problem
  • playing around with different bearing screw tightness to see if the bearings were too tight and causing drag
  • removing the spacer part between the Z and X axis (I can't fully tighten the x/z connector with the spacers in place, is that normal? there's about a .5mm gap and if I go any tighter the plastic starts to crack / warp.)
  • removing the Z-rods entirely and seeing if the gantry would fall under it's own weight. It didn't.
That last one really surprised me, I thought for sure that it would fall but it did not. At this point I'm not even sure which direction to start troubleshooting in. Any help / advice / input would be incredibly appreciated! Thanks guys!


Did you change the firmware to account for your allthread Z screws? My firmware is set for T8’s.

Allthread will not drop on it’s own. Allthread has a max speed of 8mm/s.

Always, every time, start all Z moves from 0, the bottom. If it skews it should bind, it should pinch the table. Pushing it while it is up will break things.

Carefully move it all the way down, and if the firmware and speeds are correct see if that improves anything.

How tight are the sides to your table, do the Z rails stick? I sanded my table sides and it is smooth like butter but it also has about 1/32-1/16" gap between the table and Z rails.

There should be a 2mm gap equally all the way around. If it touched it would not be able to tension.


100% the issue.


1 Like

They’re T8s. I just finished a conversion from LR1 to LR2 and on the LR1 they fell on their own.

[quote]Always, every time, start all Z moves from 0, the bottom. If it skews it should bind, it should pinch the table. Pushing it while it is up will break things…

…How tight are the sides to your table, do the Z rails stick? I sanded my table sides and it is smooth like butter but it also has about 1/32-1/16″ gap between the table and Z rails.

definitely skewing. At Z0 the z rails are almost but not quite touching… I can fit a piece of paper in there and that’s about it. At z100 there’s a much wider gap, and the higher I go on Z, the less issue I have with the binding… in fact at a certain height it was working as expected until I started dropping back down to the sub-100 range.

So would you guess that’s a bad / warped T8? coupler maybe?

The gap should not change.

Can you upload some build pictures, something is wrong.

When you move 50mm on the Z does it go exactly 50 on both sides? You might want to go back to the Z axis wired in series from one driver so we can eliminate a ton of issues, as you gain nothing from two drivers other than a ton of possible issues.

Could it be trapezoidal? The z rails aren’t parallel across the table (or aren’t perpendicular to the table plane) such that one side moves either closer to or away from the other side.

1 Like

uploaded a bunch of pics:

All these pics are at z100 except the measuring ones. Looks like at Z0 the plate is about 1 & 5/8 from the table, at z100 the plate is about 1 & 7/8

The only thing I can see from those pictures are you XZ parts are really close.

Take the X rails and lead screws out, make sure each side moves up and down really nicely, with very minimal effort. Then when you put the X back on make sure you build it square. Measure from the outer (by the wheels) edges to the other side, measure form the top and bottom, All of those numbers should be exactly the same, build it against the already square stop blocks.

I think the issue here is you put it together 100% and there are a few small issues adding up to it not working. Just do it again, measure as you go, test all the fits as you go. I have used mine for many hours now and I am going to give it the once over myself to re-tension all the bearings. Should take 30minutes at the most.

The pictures with the measuring tape, whatever that is should be the same. That is way way off you should be able to see what happens.

In the picture with the 2" tape measure, your lower bearing is off center? The head of the bolt is almost hitting one side and has tons of room on the other. What is going on there, that should not be possible?

Matter of fact I can see the inner bearing race on the bearings on most of the pictures. You have to use my recommended parts, those bearings being loose in the wind will not allow you to build a functioning machine.


So this sounds like a problem but I’m not exactly sure what you’re referring to… I just reused the hardware from the low rider 1 I had did the bolts or bearings change from LR1 to LR2?