Vectric Aspire

Hi all,

I just got a copy of Vectric Aspire, I saw on the milling basics that you have an Aspire PP.

Ok I know that I go to toolpaths and install PP but, the test 5 did not work? I must be doing something wrong.

I have cut out a couple of things and saved my file as V-Carve G-code.

Also I see a lot of posts saying to read the G-Code, do you do this in note pad?

Thxs Rob

Hi Rob,

Could you be more specific about your PP install? It works on mine. I did notice that it will have to be the only choice. You can’t select it from the list. When I installed mine, it made it the only post processor I could use. If you have a laundry list of PP’s then that’s your problem.

As for the G code. I don’t know enough about it but I believe that when I install my SD card into the LCD, I can manipulate the code there - I think. I don’t mess with it because things work fine. I did notice that I had to change the X, Y, and Z axis around when using this Test 5 PP so they move in the correct direction.

My Aspire was a gift and the kids forgot what email they used so I have never been able to download the extra files for carving. That sucks because that was the reason I wanted the software! They bought it last year and never wrote down the info or kept the email so Aspire told me “too bad, I have to buy another copy. Geez, the software was expensive the first time!”. Still, my software works.

Hi Mike,

if you give me your email I will send you a copy of the free clipart that I got with my copy.
I went on the basic milling page on Ryan`s site and saw that they had Aspire PP listed. Clicked on link and found Marlin test5.pp, this did nothing when I tried to install. Searched around and found zip file for Marlin_mm.pp, downloaded this and unzipped, tried to install and nothing happened.</div> <div></div> <div>I must have the wrong install file???</div> <div></div> <div>How do you work with code on the LCD, once I hit print that`s it nothing else works.
Thanks for the reply.
1 Like

To read or edit gcode, you can use a text editor. Notepad works. If you do it often it’s worthwhile getting a text editor with a bit more muscle. Common editors for beginners are:, microsoft visual studio code and sublime text editor.

UPDATE: I sent you the dropbox link in your email. Thanks and cheers.

Hi Robert. Here’s my email address. the clip art files will make life so much easier. I appreciate you sending me the files.

Hi Rob,

Here’s how you can install the post processor in Aspire.
First close Aspire.
Get the post processor file which is: “Marlin_mm test5.pp”
and put it into the folder: C:/ProgramData/Vectric/Aspire/V9.0/My_PostP
(note that “ProgramData” is a hidden folder and “v9.0” may be different depending on what version of Aspire you have)
Put the test5.pp file into that folder.
Now when you run Aspire, the Marlin pp is the only choice available to you to generate your gcode.

Hope this makes sense.


I do not have Vectric Aspire. I have the trial version of V-Carve Pro which I will be purchasing in the near future.

I found the Marlin_mm-Test5.pp file however the path to install it is not the same for V-Carve Pro as it is Aspire. Can someone guide me to where I need to copy the Test 5 file?

I found it. Never mind.

vcarve is a lesser featured version of aspire for just 2d carving as i recall

If your post processor is setup right it should generate gcode that works tailored directly for your machine. To make sure all you should have to do is edit the gcode file generated in notepad (i like notepad++) and see if it matches up with what marlin wants as far as startup/ending, zeroing and M codes used. I’ve got a bunch of different machines i run gcode for so mine are all completely different (Fanuc, Centroid, Mach) with Marlin soon as i’m building an MPCNC


Where did you find it? I’ve been looking for a while…

1 Like

It’s located across the menu bar at the top under Toolpaths. Go to Install PostProcessor and browse to it. Let me know if you have any issues.