Unable to complete a tool change

I don’t know if this is a FluidNC, Jackpot, or gcode issue but I cannot complete a tool change on my MPCNC. EstlCAM (using the config from the Jackpot docs page) uses M0 to insert the pause to change tool, connect the probe, disconnect the probe. However, I cannot get the program to resume afterwards. The webGUI does not show a resume button and using “~” in the terminal does nothing. I have not been able to try a physical button connected to an input yet but will be soon, hopefully.

Is anyone else seeing this?

Using FluidNC 3.7.8.

in the console type ~ That is resume. Took me forever to figure this out as well

2 Likes

No.

Make sure you are connected still. I tool change everyday. If it is a long job I use “~”. If it is a short one the resume button is there.

~ doesn’t work. It stays frozen.

I just had to reflash the ESP32. I’m going to see if that changes anything.

It’s really annoying that I can’t get this to work since it’s a 5 bit process to make my cribbage boards. Changing would be easier than having to load a new program each time.

But all that will have to wait until this afternoon since I can’t get the board to connect to my wifi right now so I can’t look at things while working.

Are you using STA mode??

Are you sure you are connected?

The only other thing could be bad Gcode, zip an dupload your gcode or copy and paste the snippet before and after a tool change by about ten line either way.

I will do that after I run another test this afternoon. I’m using the webgui from two different devices and netiher of them would work. I’ll see if reinstalling to 3.7.10 makes any difference.

Stick with 3.7.8 for now. I know that works 100%

Are you using STA or AP mode?

Neither one works but the last time I tried was with AP mode. I was getting memory issues (I think) with STA mode.

Make sure you are only connecting one device at a time. Make sure you do not have auto connect enabled on any of the wifi devices. If you have multiple devices connecting they will get blocked while it is in motion, but as soon as it pauses for the tool change they will connect and crash the device.

This is not a know issue so it is either your Gcode, or your device/s.

I suggest changing the password or ssid and only connecting with one device (not automatically). Also sounds like you have been messing with the settings so it is best to wipe and reflash to make sure you did not save something funky.

Just ran a test after completely reinstalling 3.7.8. Everything worked fine. This problem started before I made any changes (except adding some macro files) from the default setup from the store. Not sure if something got corrupted in my install or if it was trying to use my computer and my phone to control from the webGUI but it’s working now.

Thanks for the help.

2 Likes

Holy COW!, I was just looking everywhere for this!!! Thank you!

1 Like

No problem! Glad it was here to help!!!

i had not programmed the tool change til now for estlcam in Fluidnc. I was going to rip my shop apart.

I also thought that estlcam said change to tool… but I do not see that. It is very tough to know what tool is changing to.

When you switch over to V3 webui you get a fancy pause/play button LOL

2 Likes