Stepping too far (about double)

Looking for a little advice.

I’m helping a friend with building the mp3dp. Printed and CNC’d all the parts, then pointed him to the V1 store, where he bought all the parts, so everything we’re using is the “standard” kit.

The problem is, the printer is stepping twice as far as it’s supposed to. We’re using the MiniRambo with the LCD controller. I was letting him borrow my Mini while we waited on his to arrive, and everything worked great. Flashed the SAME image to new board, and now everything is moving too far. Not just during printing, but during jogging the printer around. Using the 10cm jogging command, the machine will move 20CM.

Using the firmware on the MP3DP page for the MR with no alterations. Anyone seen this?



What are the steps/mm? That’s either wrong, or you have a different amount of microsteps. Is the mew board also a minirambo?

2x is really common because it’s the difference between 1/32 stepping and 1/16. Or 1/8.

It is the newest version, 30X on the bootscreen? Double check you didn’t get the ramps firmware on it somehow. It really should be good.

Its set for 200 steps/mm. The board is MiniRambo from the site. The firmware is straight from the MP3DP. I’m using the old printer firmware, because the current repository on github automatically starts turning the heater on and heats it way up. Not sure what the deal is with that, but for the moment, but I just want to get this board going

The firmware I’m using is MP3DP511_MRambo .

That means you are not using the right one.

Make sure you set the correct extruder thermistor, and Extruder steps.

Thanks Ryan. I wound up changing the steps in the config file. Cut them in half and everything worked fine. I’ll download the suggested firmware and try it out.