Spindle interferes with SD reading

I’m close to having my MPCNC up and running, the only thing left to solve is the spindle “interfering” with reading the SD card through the LCD.

Since finding DeWalt tools in the EU is quite hard and I’ll mostly be working with 1/8" bits, I bought this import spindle which seems to be the same one linked as the second choice in the BOM. Puzzling enough, it does not have a ground/earth terminal for the 110/220v side.

If the spindle is powered down I can use the LCD to read from the SD card with no problems, but as soon as I turn it on evident interferences come up while browsing the SD: garbage characters on screen, missing files or folders, uppercase instead of lowercase… More examples in the pictures below. The rest of the LCD’s menus seems to work fine, so I guess the problem is only relevant to the more sensible SPI bus.

If I try to start a cut from the SD it eventually starts and runs fine for the first few seconds, then begins to randomly move around in the workpiece or skip segments. Thankfully I’m running these first tests in foam so no harm done up to now. The crown test came out perfectly when using the pencil attachment instead of the spindle, I even used it to draw the position of the dog holes on the spoil board that I then manually cut with a drill. Not a single hiccup without the spindle connected.

I’ve tried connecting the earth wire to the spindle transformer’s chassis to no avail, as well as moving the transformer farther away from the RAMPS and the LCD. Could it be that the spindle wires, running inside a cable chain along the steppers’ ones, crosstalk and generate enough noise for it to travel up to the RAMPS and LCD board? I’m kinda out of any other thoughts…

1) Did you buy everything from here?
a) I’ve bought the components from third parties (I live in EU) but tried to stick to the BOM as closely as possible.
b) I’m running a RAMPS v1.4 with the Full Graphic LCD and A4988 drivers.
c) The same behavior has been observed on both the MPCNC’s stock firmware (the one downloaded from here) and a fresh copy of Marlin v1.1.8 with the configurations appropriately ported from the stock ones.

2) Are you using end stops?
a) No.

3) Mac or PC (windows xp, 7, 8, 10?), linux?
a) Linux, but not really applicable in this case I guess.

4) Include a picture so obvious errors might be spotted.
Link to Imgur album.

First off, thank you for going the sticky questions, it actually does help a lot.

I bet you can probably ground the power supply’s metal case, that might help. Physically move the ramps as far from the spindle power supply as possible. Other than that try moving any wires related to the spindle away from the rest. It looks like you have them all bundled and in a cable chain together. I would say run them the opposite way, not bundled with the rest. any where they need to cross try and cross the wires at 90 degrees. When they run parallel they have the highest chance of picking up noise.

How long are those display cables? Might be a touch long.

Thanks Ryan, seeing a creator of a project following through with it and most of its users really is an awesome thing. Great job!

I’ve tried re-routing the spindle’s cables like this, but unfortunately it had no impact on the issue… I’ve also tried changing the power strip I’m using with another one that doesn’t have a surge protection circuit - it may have helped a little, but I could not get consistent differences so I’ll call that a draw between the two strips.

They are 60cm long. Longish, I agree, but I had no troubles with LCD cables of the same length on my past 3D printers. I’m looking around and I’m seeing that this size is the most common in RAMPS kits.


So far I’ve tried:

  • Changing the RAMPS' PSU.
  • Changing Arduino, RAMPS shield, stepper drivers, LCD (basically another complete kit).
  • Changing SD card size and format type (512MB/8GB, FAT16/FAT32).
  • Updating to a newer firmware (Marlin v1.1.0 -> v1.1.8).
  • Changing the main power strip.
  • Re-routing the spindle's cables perpendicularly & away from the other cables.
  • Moving the spindle's transformer away from the RAMPS.
  • Connecting the metallic case of the spindle's transformer to the earth/grounding cable of its 220V plug.
In case it could be of interest, the foam chips really like to stick to the spindle's body - I'm assuming it is because of static electricity, is that a normal or a bad thing?

I’m getting kind of fed up with these import spindles, but cannot find much else in the €100 range that accepts 1/8" bits without ridiculously expensive or proprietary collets.

Little update: I’ve tried installing an EMI filter right before the spindle’s transformer, but if possible it made the problem even worse. I’ll wait a few more days in case something else comes to my mind and then I’ll either setup USB controls or return the spindle.

Just for giggles, wrap the lcd cables in some aluminum foil, then alligator clip a ground wire to one side. Electric motors throw out a crap ton of emi, so I really think this is the issue.

Since we’re talking Europe here you should use the correct terminology… It’s actually just a bit over 0.9 crap tonnes of EMI.

Well, I guess that it can’t get worse, could it? I’ll try that in a couple of days.


Juuust a little under 1.21 Gigawatts.

Here’s a little tip for the other import-spindle-adventurers out there: throw away any brushed DC spindle that you might have. Do not waste time and money trying different ones and/or brands. The way to go is - drum roll… brushless.

Seriously though, as soon as I replaced the brushed spindle with a brushless one (namely this), everything started working flawlessly and I could even run the spindle’s cables alongside the stepper’s ones.

Here’s the test cut - old, erratic cuts on bottom and the newer, correct one on top:

I had time just to try a single cut, a bits holder, and luckily I had no noise-related troubles. However, my Z motor lost steps while drilling holes that are the same size of the bit and the machine was overall going reeeeally slowly; I must’ve screwed something up while setting Estlcam. But that is a subject for another thread!

That looks like a nice spindle.