SKR Pro v1.2 no usb, no printer attached error

I am using the clean firmware.bin that worked before and I am getting the .CUR ending after flashing every time. I have tried a few times now but still no go. I do not have another SD card but I suppose I could go buy one to try it.

How do I flash the bootloader?

I flashed it using a usb to uart adapter. I know there are a bunch of ways to do it. But I found some tips in a random github issue thread.

It is a more advanced thing to do. So if none of that makes sense, it might be better to try everything else first.

Well the usb port is not working now so this might be a thing to try. If I can get the adaptor what am I flashing, the same firmware or something else?

Anthony… Having same issue as you. However won’t flash to .cur. Following for bootloader steps.

@jeffeb3 Would this work? Totally out of my comfort zone of expertise now. https://www.amazon.ca/Adapter-Serial-Converter-Development-Projects/dp/B075N82CDL Will order if so.

How to flash the bootloader.

@aleonardo

1 Like

OK, thanks. Your link was to Amazon Canada, didn’t notice and they said they could not ship to me. lol, changed to US and will get it tomorrow then I will give it a try.

Yeah. That is what I am talking about. That is one of the pricier ones (unless I missed some inflation somewhere). I believe you can also make one from a regular arduino, but I have not tried it myself. They are very useful tools.

It has been a while, and I just skimmed that video. But it looks right to me. I believe you need to make sure you do not power the skr from the regular power. I couldn’t get st link to work in linux, but there was an open source command line version.

This is why I didn’t want to describe it in detail, I have an advanced set up.

If you are not getting it to change to .cur, then I would look more closely at the power and the fuses. Those are not the same issue.

the firmware file does change to .cur but not seeing it via usb in pronoterface and the TFT screen says ‘no printer attached’

This is confusing, because Marko is jumping in with different symptoms.

Yes, it loads the firmware and I get the .cur file afterwards but just no connection to the TFT and no connection via usb. Do you still recommend flashing the bootloader firmware?

I understand your symptoms. I was responding to Marko, which is how you got confused.

I don’t think I ever recommended it :). I just suggested that it may fix the issue. I also said, you should do that only after you’ve exhausted the other options.

1 Like

I just received the link adaptor that Marko recommended and the pin labels do not match up with the SKR. I do not think it is the correct one. I ordered the St-link referred to in the video and will get that tomorrow unless someone knows it the pins translate to what the board says. The link I got today has pins labeled CTS, RTS, RXD, TXD, GND, VCC. The SKR pins are RST, SWC, GND, SWD, 3.3.

The uart pins I used are on a little 4 pin bus, near the reset switch labelled UART. From the board you just got, it would be the GND, VCC (3.3V, IIRC), TX, RX. But probably not in that order. I would have to look it up.

Is there anything else you can try before flashing the bootloader again? :slight_smile:

I found the post where I documented what I did. I did this in Linux, not windows, but here is what I did:

Yes, there are a lot of fake ST-link units out there… I ordered one and ended up with something that is basically just a usb-ttl adapter ( like you have), a genuine st-link has swclk, swdio, swim, rst, gnd, 3v3 and 5v0. I’m sure most of the Chinese sellers don’t understand there is a difference!

Great news, it appears to have worked. I flashed the bootloader and then was able to see the card via usb and once I flashed the marlin firmware the TFT was able to see the printer as well. Now I have to rewire up the stepper motors and the endstops as I had taken everything apart to try to figure it all out. Thanks Mike and Jeffeb3 for all the help. Hopefully all will go smoother from here on out.

2 Likes

That is great news. I wonder how it got messed up in the first place. But I am happy it is cruising now.

Did you use the uart, it wait for the stlink?

I got the st-Link and it all worked like a charm, 'cept had to bum my son’s windows computer to get it to link up. Mac running windows in parallel didn’t cut it.

1 Like

Ugh. So sorry about the wrong item. I’m also having the same issue now with my replacement board that says no printer attached. Will follow above.