SKR Pro Trouble shooting

Hello, looking for some troubleshooting tips to determine if I have a bad board or not.

27.x Mar 22 2023 in 120Mhz


  • I have no problems with X and Z
  • I rebooted the board each time I tried a test

Here is my issue.

The Gantry does not move correctly

If I try to move the Gantry. The Y2 stepper motor (sm) spits and sputters, and sounds odd as compared to the others. while Y1 sm sits still. Also, an alarm goes off while displaying and error “Error:Printer halted, kill() called!”

Then If you unplug the Y1 sm (and leave it unplugged) from the board and try to move the Gantry then Y2 sm sounds normal and moves like it should.

Going further , If you switch the Y sm on the board you then I get the exact opposite result.

I have also tried swapping the Driver with the same results as above.

I forgot to mention I also tried swapping the sm driver around as well. I had the same results

Meaning, Y1 sputters and Y2 is fine? Then I would look at the socket of Y2 and make sure it is soldered. They have missed some solder pads before. The sputtering sounds like a wiring issue (which includes the traces on the skr)

I don’t recognize this format. Use the skrpro duallr version from MarlinBuilder releases. I know that works and has worked on hundreds of builds.

So this board came out of the V1 shop when I ordered all the other. I figured it was loaded correctly.

Question, when loading the Bin file does the Bin file also require the Marlin folder to be on the SD card as well? The Firmware Instruction mention only the Bin file but when you unzip the folder, there is also a zipped Marlin folder within it.

just the .bin file is all thats needed. Once its loaded onto the board it will change to .cur on your sd card

1 Like

Yes I tried it that with both the V1 Engineering tested version and the Forum Tested version. Each time the file name was changed to .cur.

I had the 2 main plugs from the LCD removed each time.

Oddly Now after this second time, my laptop wont recognize it as a connected device anymore. I rebooted my laptop, tried re flashing again. I also removed all the wiring to the stops and the lcd.

Still wont show up in comm ports.

I just ordered another board from the shop. Maybe this one will work.

@vicious1 is there something you know of he could try?

Pictures from the back would have been good I guess. @hhubred You could also wait for the new board. :slightly_smiling_face:

Here you go.

I am really not good at soldering, but I can’t see a bad solder. Maybe one of the others can. :sweat_smile:

It was no longer being recognized by my laptop. Just bought a new board. see if it helps.

My last tid-bit for the day.

Note the light that is out next to Z0 label.

Also note the pins for Z0. The first pin is black as night. Or at least not silver like the others.

The SKR Pro doesnt have a light next to the Z0 label.

There are 6 drivers, and 6 end stops. Each endstop has an indicator LED that is supposed to come on when the stop is at logic high. (This does sometimes cause problems as well on this board.) It is only for the end stops, and reflects nothing about the actual driver. It is somewhat misleading to put the lights next to the motors, at least with V1 firmware. For example, the E0 motor driver might be running the Y2 motor, but the E0 stop manages Z2 on the LR. The E1 driver manages Z2, and the E1 stop is Y2. The E2 motor is unused, and the E2 stop is Z1…

The blackened pin might be trouble, that could indicate a poor connection that is arcing. That can cause missed steps on that channel. BTW that looks like the Y channel to me, not the Z0.

Your correct, Y has the burnt pin.

Also, as far as I know, the drivers are at the wrong places. One of those in the middle has to be empty.

As far as Stepper Motor Drivers. Slot 6 (E2) is empty (Its not used in Lowrider3). If you referring to the actual Board connection that goes out to the actual Stepper motor themselves. Then EO in the middle is empty and has a jumper. As per the setup documentation.

1 Like

Okay, wasn’t sure since I use another board. Sorry I couldn’t be of more help. :pensive:

No, that is correct. The empty motor wire connector is the second Z Port, which is wires in series on the SKR Pro. (It has the jumpers on it to short the pins. No jumpers, and the motor does not turn.)

That is actually the Z1 port. The labels are on the other side. Starting at the power connectors they are X, Y, Z0, Z1, E0, E1, E2.

When you are booted up in the terminal type in M119 and show us the output please. That will help confirm what firmware you have.

I know the heatsinks have a bit of room but are they touching the pins?

Just to be safe you should remove these as well I am not sure how the SPI and UART work but I have always removed these to match the others.