RAMBo v1.4 serial killer

Evidently, I killed two Rambo 1.4 boards before I even got off the ground.

I connected my first Rambo 1.4 (V1) to the five NEMA-17 stepper motors I purchased from Amazon (V1 was out of stock). I used the USB cable supplied with my Rambo to connect to my MacBook Pro (Sierra) and then attached the Kastar 6A power supply (V1) using the slick adapter provided in the box.

Repetier-Host was able to connect to the board, but the motors didn’t respond when I tried to home or individually step them. I don’t recall the LEDs being illuminated (between the board’s USB port and the Reset button). I re-wired the power connection adapter using 14g solid wire instead of the stranded wire supplied in the box. My multimeter showed the power supply provided 12.75 volts and 3.31 amps through the adapter. I fiddled with the configuration for a few hours and researched the Repetier-Host manual but couldn’t find anything to resurrect my lifeless board.

I powered down and unplugged the steppers and USB, then attached the LCD I purchased from V1 to see if I could at least get the Rambo 1.4 to power up and communicate at the bare minimum. I found the forum posts on LCD cable orientation and tried each permutation but never got the LCD to illuminate or the LED lights on the board to glow.

I took out the 5 amp fuses and discovered neither of them had continuity. This surprised me because I had been following AESD protocol before I removed the board from it’s protective bag. At this point, there was nothing left to lose, so I jumped the 5 amp fuse connections. The board LEDs remained unlit.

I ordered another RAMBo 1.4 from V1 along with several fuses. I did not connect anything to the new board this time other than the adapter plug for the power supply. At this point, the adapter was not connected to the power supply. As soon as the adapter plugs touched the connections on the board, the power LED brightly glowed green and then went dark. I knew that wasn’t good but I connected the power anyway and confirmed that the new board was now dead. The 5 amp fuses on this board still have continuity, however.

I don’t want to order a third Rambo…at least not until I figure out where I went wrong with the other two. A picture of my power adapter is provided to demonstrate the polarity. I referred to the diagram in the web link to attach all other connections on my initial board. Thanks for your advice…or sympathy.

[attachment file=97554]
[attachment file=97555]


You are powering it backwards. There is a polarity diagram next to teh first port.


Whoops… Pardon me while I go vomit before ordering my third board…

Changing the tiny fuses should fix it…except for the one you bypassed.

Ryan, you’re a genius! Good thing I ordered six fuses… Now I have two working boards. I can take over the world!! (insert evil laugh here; cue thunder and lightening)

Thank you very much. On to the next hurdle…

That is why I stopped bothering with cheap boards. Properly fused and protected is worth the money in my opinion.

(no more bypassing things from you!!!)

1 Like

Was the issue here with the polarity being reversed, or was the barrel plug also part of the issue?

I’m working on wiring my rambo 1.4 as well. (Purchased from V1.) I’m following the instructions and they say to cut-off the barrel plug, but my power supply came with the barrel plug-to-screw down adapter. Do I still need to cut-off the barrel plug or is it safe to use the adapter; as long as I don’t reverse the positive and negative?

What exactly is the issue with the barrel plug anyways? I see post that it will fry your arduino, but can’t find an explanation. Or is this all just referring to a board style that I do not have?

Barrel plugs get loose over time. Most of us attach the rambo to the lowrider, so you don’t wan’t the plug popping out mid job.