Please Help

i have the MPCNC i’ve tried the CNC Shield and the Ramps 1.4 i get it to move i calibrate the steppers for 100mm

and it goes 100mm after calibration i put in 10mm it goes 25mm put in 290mm it goes 310mm

what am i doing wrong please help

I have no idea how it changes, something is wrong. Step rate feedrate, loose pulley, software. drivers, voltage, pulley, steppers. You have obviously used non recommended parts so you need to list your parts so we can help.

You need to provide a lot of details. What you are describing should not be possible.

i Am Using

KINGPRINT Mega 2560 R3 Board + LCD12864 + Ramps 1.4 + 5pcs DRV8825 Stepper Motor Driver Module with Heat Sink for 3d printer

And i am using

Witbot CNC Shield Expansion Board V3.0 +UNO R3 Board for Arduino+ drv8825 Stepper Motor Driver With Heatsink Kits for Arduino

Both do the same i am using the stepper motors from V1 Engineering

i’ve tried UGS and UGS Platform and Estlcam all do the exact same thing i’ve adjusted the voltage on the stepper drivers im out of ideas

What firmware, what settings, accelerations, size of pulleys, how are you issuing commands, what feed rate are you trying to move, what did you set the drivers too?

If you are using grbl I can’t be of any help I have no experience with it.

I can say your moves being off by a different percentage should 100% not be possible so you are losing steps, either your drivers are set wrong and over heating, your build is sticking, your accels and/or speeds are wrong. Try moving 100mm @20mm/s

My Firmware is MPCNC818_GLCD_T8 from V1 Engineering site

recommended settings through same site

G2 16 tooth pulleys

G2 Belt

4 Nema17 stepper motors 76oz of torque

Ramps 1.4 2560 R3 Board+ Arduino Mega (original) not a copy

issuing commands through RepetierHost cause Estlcam crashes evertime it sees the board

feed rate is 5mm a second

drivers are DRV8825 they are set to VREF 0.7




oh BTW they do have the 3 jumpers on them to make them 1/32 microstepping

i know thats a factor in the stepping motors

I’ve been calibrating and setting up cnc routers (industrial) for years and have never seen this happen

If you tried using estlcam, it probably flashed it’s firmware on the board. Check to make sure you have the proper firmware installed.

1 Like

Sounds like you did not follow the instructions, at this time ESTLcam is for generating gcode ONLY, not for controlling the ramps board. As mentioned by Barry, check what firmware is on the board. After that I would verify driver setup/current.