Only one motor moving during circles

Hej fellow mpcncrs,

I recently upgraded to primo version after many years using the burley version, after I put it back together and a little bit of tweaking it worked as reliable as before and better. Until I had to cut some circles. It only cut strange ovals.

After generating different gcode I found the problem on the y-axis only one motor was working.

All the straight and diagonal cuts work as aspected.

I need some help to solve this problem!

Thanks max

Check wiring first. What board are you running?

Thank you for answering. I’m running ramps mks gen 1.4 board with grbl autosquare I found here in the forum. I checked the wiring, I works fine doing linear moves

So, does that Y motor that wasn’t working work in lines and not circles?

Are the circles made using G2/G3?

Did you check the grub screws that hold the pulleys on the motor shaft?

And if it works sometimes, and the wiring was recently redone, I would also suspect an intermittent wiring issue.

Is this the mega 5x derivative of grbl? I haven’t seen that used much recently. John Boiles is still around if you think it might be firmware related.

1 Like

Thank you for your answer.

The motor works normally doing linear cuts.

Only in circles one motor is not moving. It moves to the x y position and stays there engaged while the other three are doing their moves.

In the gcode are g2/g3 moves for the circles.

For the wiring, I redid it all. Checked continuity, everything works fine, I moved the gantry around and checked again, again fine.
I tried the code on different spots on the machine always the same problem linear cuts spot on, circles only there motors working.

The upgrade to grbl esp is in the mail. And yes I’m running this ancient board with that firmware

Have you changed your CAM software or updated it since you last used the old machine? Is it possible that previously you had your CAM configured to not generate arcs and instead use line segments?

It’s hard to see how this could be an intermittent or miswired motor if the motor moves correctly in all linear moves but not during G2/G3 moves.

Does your CAM software have an option to turn off G2/G3 moves?

It will be interesting to see what behavior you have after you update to the latest controller firmware.

Does it maybe only seem to cut during straight cuts, but is being dragged behind by the other motor? The axis would be out of square then and lagging a bit behind but it is hard to notice. I had it once and the grub screws were the problem.

1 Like

Hej folks, a reflash of the firmware did the trick. Thank you for your help!