MiniRambo swap to MKS GEN L

Hi everyone,

My miniRambo no longer wants to talk to my steppers for some reason (all fuses checked).

I have a spare brand new MKS GEN L v1.0 with TMC2208 drivers. I have uploaded the dual endstop firmware (going with endstops since I’m making the change) for the ramps board as suggested by people who have done it.


  1. Does anyone know if i have to change the steps/mm going from the miniRambo board to the GEN L? If so, what should they be?

  2. Do I plug the steppers in using the RAMPS board diagram? X1 to X, X2 to E0, Y1 to Y, Y2 to E1???


Thanks guys. Looking forward to getting back to cutting, and homing!!!


Cheers John

Those two boards are significantly different, you need to do extensive firmware edits to use dual endstops and those drivers. I do not have a pre-made firmware for that.

Ah OK. I’m guessing the pins are different for starters. I did see somewhere someone sharing their dual endstop firmware for the GEN L. I might start with that and adjust steps as I need to afterwards.

Hey Ryan, is it worth sending the miniRambo back to you for a possible replacement? Is there warranty on these things? It’s definitely under 12 months.

Lights come on, display shows normal, just nothing happens when I tell it to move. As I’ve said, all 3 fuses are fine. Any other suggestions?

Have you tried re-flashing it? You might have messed with the eeprom and not realized it. Everything working except movement on all three axis is not something that is even easily possible to do.

(mini)RAMBo is totally different from MKS, but MKS is extremely close to RAMPS, no?

Perhaps start with RAMPS firmware and change motherboard definition in Configuration.h to reflect MKS (BOARD_MKS_GEN_L) and you should be almost there.

I would assume your TMC2208 driver modules obey the same STEP/DIR/EN pinout (like this one for example so you would just have to update the steps per mm. It appears to operate at 1/16th microstepping at the STEP/DIR level (with finer “interpolation” internally) so starting from Ryan’s RAMPS code, divide all steps per mm values by 2.

And then follow RAMPS plugs: X1 to X, X2 to E0, Y1 to Y, Y2 to E1.

I will re flash and see what happens. I’ll keep you posted.


Dual gets the pins edited as well.

Ok good to know. But MKS pins refers to RAMPS pins so I still think it should work. Marlin/src/pins/pins_MKS_GEN_L.h just overrides 3 things and then includes pins_RAMPS.h.

Hey guys, update:

I got the MKS GEN L board plugged in and working, but I haven’t hokked up any endstops yet, so I can’t report that the endstop work (yet). I cut for about an hour and it’s working good.

The miniRambo, I tried to reflash, but it’s not letting me. I have installed drivers, tried different USB cables, different Arduino versions, you name it. It verifies, then says ‘uploading’ and just sits there and does nothing. An orange led flickers a couple times but that’s it. I read somewhere that it may be missing (or corrupted) the bootloader. Whereas the MKS board uploaded the firmware straight away without any issues.

@Jamie I read somewhere that people have successfully converted to the MKS using the RAMPS firmware, so I don’t see any issues. A bonus is I can now use my MKS TFT screen on the serial port to jog, much quicker than using the knob.