Flashing LED T and R when connecting USB

I’m using a RAMBo 1.4 running GRBL and it was working until today. I was doing some cable management and afterward when I went to jog the machine, none of the motors would work. They wouldn’t even turn on when power was applied as they usually do. I tried flashing the firmware again, and Arduino IDE says it succeeded. But when I try to connect to the COM port I get two amber flashing LEDs (R and T) and the motors are unresponsive.
Did I kill my board? Did I blow a fuse? I tried to find information about the flashing LEDs, but I couldn’t find anything.

Are you sure you did not knock loose the power wire? On a Rambo board, there are separate power connections for the steppers and the logic. Usually people just jumper between the two. But if you’ve knocked loose the jumper and are only powering the logic circuit…

Yup, I make sure the board was getting power properly. I made sure the connectors were good and tight and the wires were screwed in properly.

It turns out it was a blown motor fuse. I’ve invested in a voltmeter and bought some spare fuses in case that happens again. The LEDs keep flashing even when the board is running, so I guess I just didn’t notice it before. Sorry for the confusion!


Thanks for letting us know the final outcome. So often the person who asks a question just disappears, and we never learn the real problem.

1 Like