Faulty Bed Heater Rambo 1.4?

Hi all, we’ve been using v1.4 Rambos to power MPCNC’s and TAZ 3D printers at our Fab Lab for quite some time now. Recently the Rambo blew out on my TAZ5 at home and I ordered a new one to replace it. Upon installing it tonight and testing all the wiring (thermisters, steppers, limits, fans all work fine) I noticed the bed heater won’t work. I’ve tried the following so far:

Replacing bed heater fuse
Checked continuity on bed heater wires, replaced mosfet plug
Tried another bed from a working printer
Installed older firmware (2017) was using latest prior
Created entirely new wire connection to bare contacts on bed
Attempted to heat bed from extruder socket (blew F3 fuse, replaced it, decided this was dumb)
Wired bed heater mosfet directly into multimeter, gets 2V consistently when powered (should be 24V)

It’s got a 120mm fan right on it so it should be cool. Red light turns on when heating as it’s supposed to. 400W power supply worked fine taking the bed up to 85* + in the past. I’ve been crawling forums looking for folks with similar issues and most of them find burned out parts, of which I can find none.

Any suggestions? I’m out of ideas. Do these things come with a warranty? It’s a few weeks old but I just took it out tonight. Thanks in advance to anyone who can help!

Compare the + and a ground somewhere else. That should be 24V. When the heated bed is off, the minus is floating, but when it is on, it should be ground.

Can you post a picture of your board wired up please.

Thank you fellows both so much for the help! Here are some photos of my troubleshooting:

bed heater wiring mosfet - it’s a dual extruder system

The forum rules only let me post one image here and I can’t post links - but I put more online:

  • jeffginger [dawt] com/files/taztrouble
  • yellow thermistor is bed temp, reads out just fine
  • connections to the bed
  • prints in PLA without bed heat okay (fast test job last night)
  • powered extruder heater mosfet getting 24v as per usual
  • powered bed heater mosfet getting 2v… both register 0v when off

yellow thermistor is bed temp, reads out just fine

connections to the bed

extruder voltage 24v

Bed voltage only 2v???

System still prints fine with no heated bed

The one I am most interested in is the 6 port plug, can’t see it.

Why do you have the 2 fans connected?? (fan0 and fan1) that will kill your board when you power either one on.

There are only 5 plugs…

As for fan 0 and 1 being connected… I can’t believe I did that. I don’t remember why I did that, and it is clearly very stupid. I think it was from troubleshooting with a dual extruder (it’s not currently plugged in nor does the board have the dual extruder firmware) a while back. Just pulled the 2nd one out. I knew I was being an idiot somehow, thank god I never turned that socket on. Thank you for pointing it out. Bed heat still doesn’t work :confused:

power input A, do you have it plugged in? Fuse F4 is it still good?

Checked the F4 fuse first thing… BUT - I should have thought to replace the power connector. It looked fine but I replaced it anyway just now - and it works! I think! Thank you!!

1 Like

Is there any way to tip you guys or donate to a good cause in your name??

1 Like

Pardon me for asking what might be a very silly question. But why not simply switch this Rambo board out for the one on your MPCNC? Most MPCNC’s don’t need to use bed or extruder heaters anyway. Since that board works fine why not use it in the TAZ?

It really is not necessary, just glad you got it going.

If you are still inclined to do so here is Heffe’s - https://github.com/sponsors/jeffeb3

I have the donate link at the top of the main site.