Estlcam Scale not right

When i make a basic 76mm x 76mm box in illustrator and bring it in to Estlcam it shows up the proper dimensions yet when I save the project for my MPCNC and go to carve it out it is massively bigger than 76mm.

1 Like

Are the g-code files being outputted/saved in inches rather MM, i personally don’t use Estlcam so am unsure of how to set it, but somewhere there is likely a setting to export the files to tell the machine what units to use.
I’m sure others with more experience in Estlcam can answer more comprehensively.

I have set up Estlcam the way that the guide shows. What do you currently use?

When you import an SVG into EstlCAM it requests units. There’s the first place to check. If it’s not asking, you may have saved previous preferences and told it not to ask again.

What is “massively” bigger? 25X the size, like inches instead of milimeters?

Check your tool diameter is reasonable. Using a 1/8" bit but generating code for a 1/2" bit, cutting your square will be about 19mm too big. (Might qualify as massive to me.)

Check that you are outputting your GCode in mm. Then look at the actual GCode file. Look at the G0/G1 commands, and see that it’s a reasonable approximation. Assuming a 1/8" bit, cutting the side of the square should be a move of about 79.18mm

1 Like

The steps per revolution might be off in the settings. Or, if you use external drivers, the little switches might be wrong.

1 Like

How can I calibrate the steps/mm for X And Y?

Yes I’d say about 25x bigger then what shows up in Estlcam. Will look in to this later on today.

Hi Adrian,
I ran into the same problem and it turned out to be a simple calibration problem.

Make a calibration pattern, i.e. a drawing pattern of known dimensions, e.g. like a ruler.
In your firmware settings in config.h (Marlin) you will find the steps per mm setting for each axis. The default set by Ryan is 200 for x and y and 800 for z.
Let your machine draw the pattern and measure the actual size.
Lets assume your reference pattern is supposed to be 100mm, but comes out at 125mm.
Simple math works as follows: actual steps needed = (100mm * 200 steps )/ 125mm
Result: 160 steps/mm
Take that result and update the value in your config.h and load it to your board. X and y should be the same value.
You can also override the values via a manual GCode terminal, such as in the manual control of the repetier host.
For example the command: M92 X160 will set you X steps per mm to 160.

I hope this helps

See what Andrew wrote, I think you can only change it in Estlcam when you use it for everything.

after updating X and Y steps the movement is super slow now. how could i adjust this?

Speeds are adjusted in EstlCAM as a part of the tool definition.

I would suggest that you look at the GCode that EstlCAM generates to see that it is appropriate. The code is reasonably well commented.

For example, I have GCode that cuts a 400mm square. The code for “Part 1” starts like this:

;No. 1: Part 1
G00 X-1.5650
G00 Z0.5000
G01 Z0.0000 F180 S10000
G01 Z-2.1500
G03 X0.0000 Y-1.5650 I1.5650 J0.0000 F1440
G01 X400.0000
G03 X401.5650 Y0.0000 I0.0000 J1.5650
; etc....

So this is basically:

  • Go to X=-1.56mm, Y=0
  • plunge the bit in to Z=-2.15mm (2.15mm DOC)
  • Make a quarter circle to X=0, Y=-1.56mm
  • Move X 400mm.
  • Make another quarter circle to go to Y=0

Those quarter circles will actually make a sharp 90 degree corner, once you account for the radius of the tool, which is the same as the radius of the circle.

Other things that you will see in there is that my plunge (feed) rate for Z is set to 180mm/minute, (3mm/s) and the forward feed rate is set to 1440mm/minute (24mm/s) for this cut.

By looking at the GCode in a text editor, I can verify that EstlCAM is doing what I want, therefore, if I’m not getting what I want, it’s the machine’s fault.

See what Dan said.

Ryan’s explanations for max speeds and acceleration are also helpful.
Those should be ok, provided you used a pre-configured version.

If it was moving fast before, it sounds more like a feed issue.
In Estlcam check the feed rates given for the tool you use.

I had to adjust my steps per mm for all three axes in order to get accurate cuts. Honestly I just tried to cut a 50x50mm square on a few pieces of scrap wood and adjusted the steps on my TFT on the fly, that worked best for my build and situation.