Estlcam moving the wrong direction

when I run the pre made crown gcode it executes properly, when I try to run the file I created it crashes into the bed and tries to keep going. I believe I followed the directions correctly in the EstlCAM Setup - V1 Engineering Documentation link, looking for suggestions?

Tool setup or zeroing would be my guess. Need more info.

I also didn’t see this screen in the instructions maybe my issue is here?

I’m thinking it’s 400 steps/mm like my 3d printers…

Don’t use 4th screen. It is for controlling with estlcam firmware not marlin. Put your gcode on the flash drive and use the LCD to start the job or go through octoprint. Your feeds for the mill setup look painfully slow. You could run the pen drawing at 200-600mm/min. The a degree angle should be 90 since you are not carving. I hope this is helpful.

ok I will ignore the 4th screen and adjust the 1deg to 90deg.

that wont fix it driving into the bed tho will it?

as for speeds I dont know whats fast or slow yet, was also going to just change the depth on this file when I finaly start the router for a crown test carving.

it won’t fix driving into the bed, but it looks like you have the top of your work piece set as zero and if your 1/8" bit in estlcam is set to plunge depth of 1 mm, it shouldn’t be a problem. does each axis move as it should from the LCD marlin controls? 1 mm up/down in the z direction looks about right from the manual controls?

1 Like

yes it does look like it moves the correct amount, I can move it around from the lcd and the esp3d web server

This is what I used for my 1/8" mill (click on the wrench on the left of the tool list number).

. Those numbers are a place to start, but beyond that left two columns, I wouldn’t pay attention to them at this point.

If your manual z movements are ok, and 10 mm move on the lcd or web page plunges or retracts 10 mm, maybe you didn’t set home? from the web page, move the mill tip to the top of your work piece and set home. I don’t recall the button sequence to do this, but if the system was zeroed somewhere else, it will plunge through the material to try to get home. Verify your gcode z movement is 1 mm, then try and run your gcode. There is a code that changes from english to metric units G20 or G21 I believe, so you can verify your units are correct… 1 inch vs 1 mm is a big difference. I’m just throwing out ideas.

The test crown has a G92 X0 Y0 Z0 at the top. That tells Marlin, “This is where the zero is”. When you run the test crown, it starts drawing from there.

You can add that G92 command to estlcam so it always adds it for you. Or you can set the zero yourself. Otherwise, it just assumed wherever it started, or wherever you hooked is the zero.

1 Like

So I made this in easel then changed the .nc to .gcode and am able to draw it. ( I can’t remember if I added the g92 as well or not, I’m going to re download it and check. )

If I try to run a file that I added the g92 after the above mentioned cut it freezes and I have to reset the controller before it’ll move again?

The files all look as expected in repetier host.

I’ll have to try again when I get home from Town…

It needs to be all capitals, and not M92. It needs to be exactly G92 X0 Y0 Z0

I copied and pasted into the files via notepad++, I’ll be home soon to confirm

This is from easel

Added the G92 and it works as seen in the below gcode

This is the pre made crown

This file freezes the controller

Maybe it’s the M03?

Freezing when I try to run anything from estlcam with or without the G92

Runs gcode from easel without issue

There are some G1 Z-0.1 F0.1 in there. Those F feedrates are in mm/min. So it is trying to move 0.1mm in one minute. It won’t listen at all until it finishes that move.

In your first screenshot, you have the “feed unit estlcam” set to mm/min. And your tool has the Z set to 6mm/min. You probably changed that later to 0.1 to keep it from smashing.

Change that to mm/sec, leave the “Feed unit cnc programs” at mm/min and then change your tool setting to 1mm/sec and try again.

Ok I’ll have to do that on Friday, I just got called to work so thats about 36h away from home.

I appreciate your assistance, thank-you.

Well I’m obviously doing something wrong, I think I changed what you suggested properly but it’s still barely moving after it gets into position ( it basically looks frozen still )

After another uninstall reboot reinstall and configure of estl cam its working enough to make a drawing.

1 Like

Working enough??? Seems really weird uninstall fixed something.