Endstops Trigger correctly , but wont stop the machine.

Hi friends,


I have assembled the endstop version of MPCNC , and tested each endstop in repetier and I get the TRIGGERED status when pushing by hand and checking m119. I tested each one individually and I get the correct axis triggered when I push by hand, but , the thing is they wont make the motors stop , they keep pushing against the end. I tried to activate all 4 endstops manualy and still they wont stop the motors.

Why I get the repetier to identify endstops correctly , but not to stop the machine?

I have attached a pic of my firmware endstop config , and the endstop itself.


Are you using the dual endstop firmware?

Yes. As in the attached picture

They only do anything when a G28 is issued, they are for homing, not emergency stops. Are you doing a g28?

I was using the lcd "Home X" and "home y" , not from repetier. Is it the issue?

I have not tried that, you should stick with repetier for all testing. Once verified then try other things.


What does M119 say?

I tried g28 over repetier and still try to go over the endstop. its not stopping :frowning:

Here you can see the lights for x endstops are on, the m119 status says x are triggered …

Using G28 when both are triggered they do not back up and touch again slowly? Do thy move in the correct direction? Are you sure they are on the correct axis and correct side (extremely common to get that wrong)?

If that is not the case I am at a loss, no one has ever had that issue before.

Obviously there is a discrepancy between cncjs using GRBL and marlin.

The GRBL command for the cheap China mills will work without any issue, but if you are using marlin, there are some problems with endswitches.

if I trigger the homing button in cncjs, it travels correct to z-high-end and afterwards to x and y-low-end (lower left corner), BUT the machine coordinates will not be set to 000 for all axes.

cncjs is sending a G10 command instead a G92. If I am sending a G92 X0 Y0 Z0 the machine zero is set correctly.

I use the latest Marlin 2.0 beta with ramps 1.4 and cncjs from the protoneer raspberry3 download image.


still fighting for a solution… but I think about to change to estl cam (Windows only).


regards Föhn