Cutting too deep

I am trying to run my first project with my Lowrider2 and consistently find the machine cutting too deep. I am using 1/2" MDF (12.5mm) and I use the manual controls to get to the origin of the workpiece. I send the gcode command "g92 x0 y0 z0" to reset the origin and I run my gcode program generated from "image-to-gcode" (utility included in LinuxCNC). I looked at the generated gcode and see the minimum Z depth is -7.0mm but when I run the program, the machine seems to want to go right through the workpiece (just keeps cutting deeper and deeper). It is as if it is using machine coordinates (when the controller is powered on) rather than the reset origin. Am I doing something wrong? Thanks in advance.

Could be so many things and you hanve not included much info.


Plunge rate, and Z rapid rate? They should be different.

1 Like

Sorry for the lack of details… I’m trying to make observations and am surprised at times by what I see. For example, sometimes one of the z movements will just spontaneously drop causing the carriage to go out of level. I have observed this after a manual move (while holding a position) and once during execution of a program. It’s like one side just gives up and the x axis guide falls.

I will try to use more basic (simple) programs to start out. I seem to have inconsistent results with the programs I’ve been trying to run (topographical map). If I could preview the gcode, that would help. I look at it with a text editor and can see extremes but not details. However, I can’t blame the gcode for the intermittently dropping side. Could I have a bad cable or something?


Sounds to me like it warrants double checking wiring. If the wiring to one of the motors has an intermittent short, then it will lose torque and can fall. Especially if it’s only one side, wiring is pretty much the only thing it can be.

Another thing you can check is feel with your finger to see if the motor drivers are hot. If you are running too much current they can go into thermal shutdown.


What board, what drivers, what is the current setting, how are the steppers wired?

Grub screws are tight?

I dealt with something similar ( didn’t know about G92) and looking at the gcode in repetierhost reassured me it wasn’t the gcode. You can get a good 3d look at the pathing that way. Good luck.

1 Like

I suspect a problem with my gcode. I have used the same gcode generation process on another smaller router with success ( Sainsmart Genmitsu Pro3018) but the Lowrider seems to interpret instructions differently. I'll try the preview feature again. It looked like scribbles the last time I tried (maybe that is a sign that my code is crap). I think i have 2 problems, one being the code and the other is the dropping a stepper.

Are there known good working gcode test files besides the crown? I ran the crown fine but sold like another test to be sure my router is working correctly. I appreciate the advice and patience with a newbie like me.

If the minimum z is really -0.7 then the only way for it to go below that is to get homed or G92 in the middle of the program which is really unlikely.

Also no matter how bad the gcode is, it can’t cause only one side to drop.

Another possibility is motor current too low and it might struggle to raise, but have no trouble lowering. You could create a gcode file with these two commands over and over:

G1 Z10 F300

G1 Z0 F300

If the machine ends up lower and lower over time, then you know it’s hardware and not gcode.

1 Like

On second thought, this is not quite true if there is an error in relative vs absolute mode (G91, G90). Worth checking, make sure you have G90 near the start, and that you do not have G91 anywhere in your gcode.

1 Like

Thanks! I ran some gcode generated by Javascript utility that came from Jamie (you?) and it ran perfectly. So I suspect my gcode generated by “image-to-gcode” is doing something funky. Good tip to look for a mixture of relative and absolute moves.

My z-axis is sticking on one side now. When I power down, I have to push it to make it bottom out. It looks like the side plate is not vertical, but I don’t know how to fix that ( shims?). I’ll work on this next. I have played with the clamp force of the vertical guide tubes and insured that they sit under the upper lip in the printed fixture. I assume that both sides should immediately and repeatedly fall after power down. The sticking side may also be the reason why the sides get out of alignment.

I am quite naive about the electronics… I got the mini Rambo board with Marlin. I’m not aware of any adjustments that should be made (e.g. current/voltage adjustments). I’m just trying to cookbook the instructions and I don’t recall any adjustments being called for.

I see some folks who have been able to configure and use LinucCNC, but I believe they have a different controller. I have a lot to learn before I get to where I want to be with this thing.

Update… I have generated some good gcode using Estlcam from the 611_plate.dxf file from Thingiverse. I set the cut depth to1/4" on a 1/2" sheet of plywood and for awhile it works fine, but then I notice that one of my sides spontaneously drops in Z. I have checked the wiring and connections and all looks fine. My motor is not hot or warm. During movement tests, things work well. I’m at a loss as to what to do. Should I replace the wiring harness and the problematic stepper motor?

I thought about this a little more… I was thinking that because the z steppers are wired in serial (per instructions), than one side will be “downstream” of the other. If too much voltage is used by the upstream motor, less is available for the downstream motor. With this in mind, I reduced my feedrates in Estlcam and I got a good run. I’ll keep trying more tests with the reduced feedrates and see if this solves my problem. I realize that this is likely obvious to experienced CNC users, but I’m just learning…

The reason I keep asking you your feed rates and rapids and hardware is this used to happen before we understood the processor limitations and changed some of the design. It has nothing to do with stepper voltage/current unless those are not adjusted properly and you are having thermal issues. But you have not really answered any of the questions anyone here has asked in an attempt to help, glad you are making progress though.

1 Like

Actually the opposite is true, when wired in series, both motors get the same current no matter what. The current is what determines the torque and the motor driver controls the current to be the desired value, so both motors should really have the same torque.

If one of the motor connectors is shorted, then current could bypass the motor instead of going through the motor, and this can create a loss of torque for that motor, but apart from that there are not very many ways that series wired motors can act differently.

Another possibility is if Z feedrates are too high and it’s marginally working, then one motor could be barely working and the other could be barely failing.

1 Like

I’m sorry that I missed some of the questions asked of me. I’m afraid some of them went over my head… I’m new to this and just learning some of the terminology.

I should have begun by saying that I have a mini-Rambo board and steppers, writing kit and other parts that came work the lowrider2 parts bundle from V1. I will look again at the setup instructions to see if I missed some adjustments. I am very weak in my knowledge of the electronics and I could well have missed an adjustment or something else. I believe that reducing my feed rates helped. I appreciate all the advice! I’m an old dog and this is a new trick… :wink:



You still have not told us your plunge rate and Z rapid rate. Those are numbers you had to put in and need to adjust for every single job.

Hover over the settings boxes in estlcam and you will see Z plunge.

1 Like

Here’s what I used for the successful run with a 1/4" flat bit (set in the tool list).


Feed rate: 20 ipm

Plunge feed: 10 ipm


Travel feed rate: 2100 mm/min (82 in/min)

Z-Axis Feed Rate: 240 mm/min

I now see there is a mismatch between what I specify in Estlcam and the settings in Repetier-Host. It seems that changing the Estlcam settings helped - I assume Estlcam hard codes the feed rates in the gcode instructions (is that correct?) and the Repetier-Host values are defaults.

I don’t see an entry for Z rapid rate. Is this entered somewhere else?



You should be having no issues with those speeds, if you are you might have the settings mixed up for the board vs input. We typically use mm/s and the board wants mm/min.


Or maybe a funky “endmill”, we has seen that a few times this week.

1 Like

The values I gave resulted in a good cut. I don’t recall what the settings were before I changed them to what I reported. Thank you so much for your advice and teaching. I’m eager to learn.

Jamie, I ran the program you suggested (repeated G1 Z10 F300, G1 Z0 F300) and the axes moved as expected. I am becoming more confident that my problem was a feed rate problem. Thanks for all the help and advice.