Cooling without dust?

Today I was having trouble with my Z axis. I thought I smelled smoke. Then I pulled off the heat sink on the Z driver and I found this:

warning graphic content

My fan blowing on my stepper drivers produces a lot of dust accumulation on the circuit board and everything nearby. The dust is extremely fine. I think because it is upside-down under the table, only the fine airborne particles ever reach the board but they do accumulate.

My best guess is that somehow the dust on the drivers caused this one to fail.

Any suggestions for how to mitigate this? Or is there a chance it died for another reason? I hadn’t touched it since yesterday when it was working.

I replaced the driver (and set the current) and now it moves fine with the joystick.

Why did just those two specific pins melt off?

Can you just blast it with air occasionally? I’m assuming the dust clogs the heat sink, which reduces their efficiency. The rest doesn’t matter much. You could also put some filter material over the fan port, but if it is very fine dust, it will get through anyway.

In my experience, if the drivers overheat, they protect themselves and shut down. So having them let out the magic smoke is odd too.

1 Like

Get an air filter for a lawn mower and tape it over the fan inlet.

Good question. So I looked up the datasheet and those are the supply pins. The Vmot (24V in my case) supply goes to two pins, one for each coil.

Don’t assume you have only one problem occurring at a time.

So after the motor driver exploded, the Raspberry Pi couldn’t talk to it over serial anymore. It would still boot, everything fine on the LCD, and all three axes moved using the joystick (after replacing Z motor driver).

  • I tried connecting the Raspberry Pi via USB to my old Sainsmart 2-in-1 from my first MPCNC. No talking.
  • I tried flashing a fresh image of v1pi onto a spare SD card, and tried connecting to the board with the original problem (MKS Gen L), and the Sainsmart 2-in-1. No talking.
  • I tried replacing the USB cable (twice). No talking.
  • Maybe the USB on the pi got blown somehow? I have a spare Raspberry Pi of the same model (3A), so try the new pi, with the original SD image, connecting to the Sainsmart 2-in-1. No talking.
  • WTF, let’s try everything new: new pi, fresh SD image, different USB cable, Sainsmart 2-in-1. None of these components were involved in the accident. Still no talking.

Fast foward past the cursing and Googling and head scratching. (Learned dmesg.)

  • Plugged USB thumb drive into each pi, both recognize it, so USB is not completely dead, probably not at all damaged
  • Found an old RAMPs lying around, both pis can talk to it, so USB is fine
  • Connect PC via USB to Sainsmart 2-in-1, it connects, but PC to MKS Gen L, which had the accident, does not connect
  • Finally I remembered that I never did set up the Raspberry Pi with the old Sainsmart 2-in-1. I had always controlled it from PC with pronterface
  • Observe when connecting Sainsmart 2-in-1 to Raspberry Pi, one time it gave an undervoltage error/warning while I was plugging it in

Conclusion: something about Sainsmart 2-in-1 does not play well with Raspberry Pi. Perhaps temporarily too much current draw, who knows. Also my MKS Gen L evidently cannot talk anymore, although it seems to otherwise work from the 5V USB supply.

I’ve got some replacements on order so I should be up and running shortly, but it was really testing my sanity there for a while.

1 Like

Does it show up in the /dev as a port?

You could connect an ftdi, or even the pi UART to the tx/tx pins directly. It might just be the usb to uart chip that got toasted.

What happened? Power surge or something?

I observed dust and tried to blow it away but it seems unlikely that it would cause a motor driver to explode. It could be that an aluminum chip from my clothes or something perhaps shorted 24V onto one of the 5V signals on the motor driver. That seems a plausible reason for exploding and theres no telling what else it might damage.

The pi seems healthy enough. I see connection and disconnection in dmesg when I attach a working device, either a usb drive or the working ramps. The non-working boards show nothing in dmesg when plugged or unplugged and no /dev/ttyAM-something appears.

I hadn’t thought of bypassing the usb chip. I have an ftdi (clone) usb to serial somewhere. Although I’m not that interested in rescuing the board, I did a quick look and the uart pins on the MKS Gen L don’t appear to be available, and anyway it might have to fight the dead usb chip.

1 Like